V6 performance on mac - far from origin, units?

Hi @Steve,

after while, I again, accidentally, bump into an interesting phenomena, which I couldn’t experience on windows before. I am working on a larger model in mm template (many buildings on site), we just keep everything in mm in our office. Comparing V6 with V5 on mac, this model is about 10 times slower in default shaded display mode. I tried to scale down the whole model to meters and mult. by 0.001 and the whole model gain much moooore speed, panning and fps is now the same as in V5. I believe this is not a case of ‘far from origin issue’ since both models (mm and m) has similar distance from origin. Could there be something about the units, size of the model that significantly slows down the model? And, moreover, is this solvable? So that I can stick to mm?


A recent change went into the V7 Mac WIP that will speed up curve drawing considerably.
The fix may be in the new 6/16 V7 WIP.

One test run on a MBP 16,1 Catalina 10.15.5
V5 - 13.5 sec
V6 - 41.4 sec
V7 - 5.6 sec


Wow, that is nice! Sorry, I did not specify it in my post. My issue is related to 3d model, namely shaded mode.

Test it in all 3 and post your results.

I can for sure try that, but have you ever experienced the thing about units/scaling?

when I have more time I can provide a model

Hi John,

this is good news. can you try that also on this model that was posted a while back?

I tried it in latest mac WIP but don’t see any difference with V6 and in shaded it’s still slower than V5.

Your TestV5 file in a default Wireframe display:
V5 0.35 sec
V6 1.65 sec
V7 1.68 sec


model in mm
V5 - 2.9 sec
V6 - 12.5 sec
V7 - 11.8 sec

model in m (scaled down by 0.001)
V6 - 1.9 sec - 52 FPS

Are those results using the same TestV5.3dm file referenced in the earlier post?

I’m confused why scaling the same geometry would make for such a big change.

Yet, it is true :slight_smile: It was my own model I was working on recently. You can check and see. It was actually a subject of my first comment.

Just open a file and run testmaxspeed command, then go to units, change to meters, let it sale by 0.001, zoom to all and run the testmaxspeed command again. I am seeing roughly 10 times better performance. Any idea why?

performance model.3dm.zip (6.0 MB)

Not here.

In V6, I opened your file and ran TextMaxSpeed
1.67 sec, 59.81 fps

Changed units to Meters, Yes to the scaling.
I got a message about history being broken.
Zoom Extents
TestMaxSpeed again
1.66 sec, 60.39 fps

Okey, that is quite interesting. Any ideas? I tried to delete all the materials with textures, but I still got the nasty result when in mm…

Since it’s display performance, it’s probably related to graphics card resources and drivers.

I’m driving two 27" monitors from the Quadro. Nothing is plugged into the Intel graphics. In fact, I disabled it in Device Manager.

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 4-7-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.92

Secondary graphics devices.
Intel® HD Graphics 630 (Intel) Memory: 1GB, Driver date: 4-11-2020 (M-D-Y).

Oh, are you running P2000 on mac? Or was it windows you tested the file in?

No, I tested this in Windows.
I’ll see what my Mac does.

Cool, I am curious

Any time TestMaxSpeed yields ~60fps, it is most likely because Vertical Retrace/Sync is ON…and you will never get any higher frame rates. On Windows, you can use -TestMaxSpeed and turn OFF VSync in the command line…but this does not work on the Mac.

So, trying to see if something increases fps if/when your first results are 60fps is futile effort…until you turn off the Vsync.


Well, my first result was 6 FPS, which improved to 50 after scaling down the model (from mm to m). That is what seems weird to me, why there is such a difference in performance.


Something is strange.
In V6 and V7 Mac with your model:
In millimetres - 56 seconds @ 1.8 fps
In Meters - 9.1 seconds @ 11 fps

In addition to changing the units, I also changed the tolerance to 0.001 meters.

at least it is not only me seeing it. Thanks for the youtrack issue…