MAC Rhino WIP and Big Sur

BIG SUR updated today and there was a Rhino update as well.

I was working in a file which began to feel laggy/buggy. This sometimes happens when I have a large file. So, I created a new file and attempted to do a copytoclipboard of a group of small drawings to lighten the load. Then the terrible Spinning wheel.
Finally forced close and opened all again. This time I tried in smaller chunks carefully saving after each copytoclipboard transfer. Then rhino told me that I didn’t need to save each time because it would archive. So tried the last small drawing…and spinning wheel. Still spinning as we speak. Will need to force quite to get out of it.

What were in the new updates?

This new info regarding shopping for a new mac. Does this mean my mac is now obsolete? Hope not.
By the way–each time it says it will produce a crash report after I force quit–but I don’t see anything. Even if I hit the “show” button.

Please don’t double post Link

Sorry. I thought I put it in the wrong place after I posted first time. Shame on me.

1 Like

@tim and @dan, FYI.

Hi @debbooth-

Thanks for reporting this.

Can you please run the _SystemInfo command and copy and paste the results into a reply here. We’d like to make sure we’re on the same page as we test things.

I was having a little trouble following the steps you provided - because it sounded like it was easy to reproduce for you. Can you help us understand the exact steps you are taking, step-by-step, because the devil is often in the details with these ones. For example, even the difference whether you typed a command or clicked a command icon is sometimes critical information, so the more precise the better.

@tim Can you attempt to reproduce this one please?


FWIW, I realized I have two MBPs at home currently, so I installed Big Sur beta on the other.

I didn’t notice big speed difference between Catalina and Big Sur, but then again, the MBP I tested on is slow anyway, so it is a bit hard to quantify based on user experience only. On both Catalina and Big Sur on this particular MBP(MacbookPro14,2, 3.1GHz) Rhino WIP is slow :confused:

Hi @Dan,

This all seemed to work OK for me. These are the steps I took to try to repeat the problem.

  1. Downloaded and installed the latest public WIP from yesterday.
  2. Opened a .3dm file I had on my desktop that I had created to test object occlusion in PointDeviation. (A surface and a bunch of points.)
  3. I made a green plaster material and applied it to the surface for extra stuff to copy.
  4. Opened a new document.
  5. SelAll on the first document and Command + c to copy it all to the clipboard. I did see the pinwheel but it was there for less than a second for me.
  6. Did a Commmand + v in the new document. Once again I saw the pinwheel for less than a second.
  7. I didn’t experience anything extraordinary.


1 Like

Thanks @nathanletwory for installing the Big Sur Beta…always helps to have more people testing internally. What @debbooth is reporting sounds to me like a force-quit worthy pinwheel…not just slowness, unless I’m mistaken.

Thanks for listing your steps @tim. That helps. Maybe we should also get a _SystemInfo from you as well so we can look for differences between the testing configurations.

@debbooth what are you and @tim doing differently, if anything?

Sorry, I am not sure how to do that. via Activity Monitor…? nothing happens when I put in _SystemInfo.

Yes force quit repeatedly. Spin dump attached if that helps.
Spindump.txt (4.3 MB)

In Rhino, you type the command SystemInfo (or _SystemInfo if you’re not running in English) and press enter. Does that help? Does it run?

This crash dump appears to be from a different application; not Rhino. It appears to be a crash in Adobe’s Core Sync application.

If you quit Creative Cloud completely - as well as kill Core Sync from Activity Monitor - does Rhino behave? (I’m not proposing that as a lasting-solution, I just want to see if that’s causing the problem or not).

Closed all applications, removed peripherals, did a restart.
Opened WIP 7.0 and the two files involved. Tried my copy to clipboard and paste…spinning wheel just the same as before.

today.txt (1.5 MB)

@debbooth, could you please share the two files you use to reproduce this problem? If they are confidential you can use to share with us. Please copy&paste the link to this discussion in the comments section. If not confidential, you can also just attach the files to a reply here.

Looking at the the today.txt there is quite a deep calltree in file searching. It would be good to see what exactly causes this.

2 posts were split to a new topic: Copy/paste slow on Rhino WIP

Hi Dan,

I have uploaded the two files. One is called church gps and the other is ada signs. In church gps–I have a red cloud around the little drawing that I wanted to copytoclilpboard and move to ada signs. Not a very taxing transfer but it has caused some consternation.

Hi @debbooth,

I see the ada signs file in the upload section, but not the church gps. Can you please re-upload it if you already did it once?



Thank you, I can see the file.