Loading Errors: GH_Scribble Levels 1, 2, and 3

mac
grasshopper
bug

#1

Running RhinoWIP 5.2 on Mac El Capitan (10.11.3). Whenever I try to launch Grasshopper via the ExplicitHistory command the Parental Advisory window loads to 100% and then the window below pops up. Been trying for a few months since grasshopper first came out on WIP for mac. Tried on two different computers with the same results.

Curious if anyone else is seeing the same issue and if they’ve been able to solve it?


Explicit History bug - loading errors: GH_Scribble Levels 1, 2, and 3
(Dan Belcher) #2

Can you please attach the definition so that we can take a look?


#3

Excuse my ignorance. How do I attach a definition?

This is what came up in my command history:

Command: ExplicitHistory
An error occured during GHA assembly loading:
Path: /Applications/RhinoWIP.app/Contents/Resources/ManagedPlugIns/GrasshopperPlugin.rhp/Components/GalapagosComponents.gha/GalapagosComponents.dll
Exception System.TypeLoadException:
Message: Could not load type ‘GalapagosComponents.GalapagosEditor’ from assembly ‘GalapagosComponents, Version=5.2.246.0, Culture=neutral, PublicKeyToken=null’.

edit:
Just a note as well I have not loaded any plugins into Rhino. I know Galapagos is a plugin so I am a bit confused on why this is popping up?


(Dan Belcher) #4

Sorry for the delayed reply. Click the icon when you are replying to a message…you can also drag and drop definitions onto the reply as well.

We’d like to take a look at that definition to see if we can reproduce this.

-Dan


#5

Actually should rephrase. What is a definition and how can I export it to share? A block definition?

Thanks!


(Dan Belcher) #6

Ah, I see the source of confusion. I should have just said “Please upload the Grasshopper file/document that is causing this problem.” Grasshopper files/documents (.gh, ghx) are sometimes called “definitions”.

-Dan


(Wim Dekeyser) #7

But it sounds like Ian is hitting the wall before he gets a definition loaded.


#8

Wim is correct. I am hitting a wall before grasshopper loads.

I open a new rhino file, execute the ExplicitHistory command, the parental advisory modal loads to 100% and I see the scribble error window. The parental advisory modal stays present and will not go away until I quit rhino. I’v never been able to load the grasshopper interface.


(Dan Belcher) #9

Interesting. I misunderstood. Thanks for the clarification. I’m not seeing this here in 5C249w. Can anyone else reproduce this issue on their machines?


#10

Just commenting I am also on 5C249w and I’v had the same issue on previous versions of WIP since grasshopper was first added.


Explicit History bug - loading errors: GH_Scribble Levels 1, 2, and 3
(Dan Belcher) #11

Try this…

  1. Quit the RhinoWIP.
  2. Navigate to Finder > Go > Go to Folder…
  3. Go to ~/Library/Application Support/McNeel/Rhinoceros/MacPlugins/
  4. Drag the Grasshopper folder to the Trash.
  5. Launch the RhinoWIP.

…what happens?

-Dan


#12

Rhino opens like usual. MacPlugIns folder only has IronPython when a new rhino file is created. After executing ExplicitHistory a Grasshopper folder is created and the same thing happens. Parental Advisory loads to 100%, Scribble error window pops up, no Grasshopper UI.

Since my command history mentions: "Applications/RhinoWIP.app/Contents/Resources/ManagedPlugIns/GrasshopperPlugin.rhp/Components/GalapagosComponents.gha/"
I did mess with removing those files one at a time and in different combinations with no success.

Here is my command history again for reference:
Command: ExplicitHistory
An error occured during GHA assembly loading:
Path: /Applications/RhinoWIP.app/Contents/Resources/ManagedPlugIns/GrasshopperPlugin.rhp/Components/GalapagosComponents.gha/GalapagosComponents.dll
Exception System.TypeLoadException:
Message: Could not load type ‘GalapagosComponents.GalapagosEditor’ from assembly ‘GalapagosComponents, Version=5.2.249.0, Culture=neutral, PublicKeyToken=null’.


#13

Has anyone managed to fix this ‘GH_Scribble Levels 1, 2, and 3’ bug yet?
I really need Grasshopper to work on my Mac but am struggling with this bug…
I have downloaded the RhinoWIP_5D132w.dmg


(Dan Belcher) #14

I presume you mean this one (RH-36518)…? Also reported in this thread…assuming they are the same bug, but we can’t be certain. We are still unable to reproduce this one. Can you help provide steps to reliably reproduce it?


#15

yes thats the one -


This is my mac spec and os-x version.

I have downloaded the RhinoWIP_5D132w.dmg.
what else do I need to provide?
G


(Dan Belcher) #16

Thanks @Giles! I think we’re good to go for now. We may ask for more information when we start to dig further into this issue.