Rhino for Mac WIP Crashes when Explicit History is launched

mac
grasshopper

#1

As the title says when I run the command Explicit History in the latest Rhino WIP the program crashes immediately. Explicit History worked on previous WIP versions. I am running OSX 10.11.4.


Plugin Database
(Dan Belcher) #2

Hi gent-

I have not yet updated my machine to 10.11.4…I plan to do this soon, but I’m on 10.11.3 for development reasons. Anyone else seeing this behavior on 10.11.4?

If not, I would suggest you uninstall RhinoWIP and reinstall it…including deleting any external Libraries you may have added (I know some people are being brave and attempting to install other components).


#3

Thanks for responding dan. It turns out one of the Libraries was causing the issue (Exoskeleton/Plankton) and once that was removed everything works again. It’s unclear if the crash is tied to 10.11.4, the newest WIP, the Library or all three but it’s fixed now. Thanks!


#4

Good afternoon, I am having the same problem as I tried to add the plugging Anemone. I have deleted the RhinoWIP applications multiple times and reinstalled and overtime it still crashes. I read the comment about any external Libraries, could you please guide me as to where to find those external libraries please!


#5

I found my external Libraries at /Users/[USER]/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/Grasshopper/Libraries


(Dan Belcher) #6

Hi Deborah-

The components are installed in:

~/Library/Application Support/McNeel/Rhinoceros/MacPlugins/Grasshopper/Libraries/

(aka /Users/<you>/Library/Application Support/McNeel/Rhinoceros/MacPlugins/Grasshopper/Libraries/)

Your Library (~/Library/) is hidden by default, so you might need to use the Finder > Go To Folder… and copy/paste the first path above.

This is the folder that you get to from Grasshopper if you go to File > Special Folders > Components

Hope that helps,
-Dan


#7

perfect! thank you so much!


#8

hi,
I have the rhino5 for mac. i want to use grasshopper, so i installed the rhinoWIP. how do i open grasshopper in that? just the command explicithistory?
much thanks,
nidhi


(Wim Dekeyser) #9

That should do it, yes. Have you tried it and if failed somehow?


#10

It works perfect! I was just a bit confused! Could you tell me of future
plans of releasing the full version?:smiley:


(Wim Dekeyser) #11

I’m not sure what a full version would entail. True, the Mac version is not at the same level as the Win version and I guess platform parity is something for Grasshopper 2.0 (What’s up with that?).

It makes more sense, here on Discourse, to ask about specific things that are missing or not working as expected. FWIW, here’s a list of such things that are unresolved on GH for Mac


#12

I installed the latest version of the WIP (5D143w) and it seems there is not an ExplicitHistory command anymore. Does anyone know if is still there somewhere? I checked and the Grasshopper components are installed where @Dan said:
~/Library/Application Support/McNeel/Rhinoceros/MacPlugins/Grasshopper/Libraries/


(John Brock) #13

ExplicitHistory runs in my copy of the same WIP.
Since it “installs” as a DMG, it doesn’t make sense to me you don’t have it.
I guess I’d recommend dragging the application into the Trash and download it again.


#14

Sorry John, I explained the problem wrong. The components aren’t in …/Grasshopper/Libraries, the folder is empty. I now remember that I deleted the old WIP using Dr. Cleaner so probably the components disappeared at that point. Is there any way I can get the components back?

Thank you