Little UI glitch w/ double vs. single row of tool palette icons

not a huge deal… just pointing it out.

if my rhino window is large enough to allow two rows of icons (in the standard&main palette at the left hand side):
(with preferences set to leave osnaps and command dialog out of that area)

then i resize the window which changes to single row scrolling:

now when i resize back out to something larger, the icons don’t change back to double row:

I am unable to duplicate this with Rhino for Mac 5.0.2 and OS X 10.10.4.

weird. the same thing i described happens on both of my computers. i’ll investigate further to see if i can come up with anything else that may be contributing.

ok, another (maybe) hint.
i have my left sidebar dragged all the way to to left (size wise… it’s as skinny as allowed).

if i drag the sidebar size to the right some (while still maintaining 2 columns of icons), then it won’t do this… or- it doesn’t go to 1 column with scroll bar… instead, it stays at two columns with scroll bars.

(not sure if it matters but my tool buttons are set to 24x24 px)

Once you reduce the height of the modeling window so the tool buttons do not fit, OS X adds a scrollbar to the sidebar and makes the rest of the contents narrower. This is why the sidebar switches to a single column of tool buttons. The scrollbar is not removed until you make the window taller than the single column of tool buttons.

It looks like you have enough tool buttons that you cannot make the window tall enough for a single column of buttons to fit on the screen. You have two options.

  1. You can make the sidebar slightly wider so that it is wide enough to accommodate two columns of buttons plus the scrollbar. Then the tool buttons will not switch to a single column when the scrollbar appears.

  2. Unplug your mouse and use only a trackpad. OS X uses overlay scrollbars when there is no mouse connected, so scrollbars do not take any space and won’t force the tool buttons into a narrower space.

The tool button area is set to show and hide the scrollbar as necessary, so what you describe is OS X behavior that I do not control.

oh. ok… i see
if i could make the window extra tall then it would sort itself out.

i very rarely encounter this but i’ll just go with a variation on option 1 when i do… just drag the sidebar to the right a bit then immediately back to the left…

thanks for looking into it and the explanation.