Curves do not show up in any display mode

rhino6

(Paul Meco) #1

Hi,

I just downloaded the evaluation version of Rhino 6. I had before been using Rhino 5 and the Beta of 6 without any issues. Now, even if I start with a fresh file, curves do not display in any view mode. Surfaces show up in Render and Shade but do not have highlighted edges when selected. In Wireframe, nothing but meshes show up and they do not change color when selected.

I have tried restoring defaults for all view modes. Can anyone shed some light on this problem?

Thanks!


(Pascal Golay) #2

Hi Paul - can you please run the SystemInfo command and paste the results? I understand the 6 beta works as expected so I’m mystified at the moment… but let’s start there.

-Pascal


#3

Has curves been turned off in the display ?—- Mark


(Paul Meco) #4

Hi Pascal,

Thanks for getting back to me - see below:

Rhino 6 SR0 2018-1-16 (Rhino 6, 6.0.18016.23451, Git hash:master @
c0b115e88c59340755c25f7822e172c79c9b530b)

Windows 7 SP1 (Physical RAM: 24Gb)

GeForce GT 520/PCI/SSE2 (OpenGL ver:4.1.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.1
Shading Language: 4.10 NVIDIA via Cg compiler
Driver Date: 8-3-2011
Driver Version: 8.17.12.8026
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp "Commands"
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp "Renderer Development Kit"
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp "Rhino Render"
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp "RDK_EtoUI"
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp "Renderer Development Kit UI"
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp "Snapshots"
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp "RhinoCycles"
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp "Toolbars"
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp "3Dconnexion 3D Mouse"
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Paul Meco) #5

Hi Mark,

No - as I said the curves are on and either way I’ve reset to default on
all views without any change - very strange.


(Pascal Golay) #6

Hi Paul - I’d look at updating the video driver asap… then let’s take it from there.

-Pascal


(Paul Meco) #7

Thanks Pascal - unfortunately - it appears my driver can not be updated because of a windows issue. It is a 10 year old computer. Rhino 6 works great on my work computer and laptop so - I guess it might be time to retire or upgrade that trusty old guy.

Thanks for your help!


(Steve Baer) #8

Try turning off GPU Tessellation in the OpenGL options page in Rhino. This feature doesn’t work very well in older drivers.


(Joeperezgreen) #9

Steve -

I had the same problem and your fix worked for me on a 2012 MacBook Pro running windows via bootcamp. Much appreciated.


(Jumichals) #10

Hi Pascal,
I have the exact same problem. Do I need to install a new video driver? Do you have any recommendations?
Here is my system info:

Rhino 6 SR4 2018-5-4 (Rhino 6, 6.4.18124.12321, Git hash:master @ 396f4c3420cadef29ac36e4307c8f98f7753c933)
Licence type: Commercial, build 2018-05-04
License details: Cloud Zoo.

Windows 7 SP1 (Physical RAM: 16Gb)

GeForce GT 750M/PCIe/SSE2 (OpenGL ver:4.4.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.4
Shading Language: 4.40 NVIDIA via Cg compiler
Driver Date: 12-24-2013
Driver Version: 9.18.13.3228
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

thanks,
Julia


(Pascal Golay) #11

Hi Julia - yes… that is practically the stone age for video drivers - get the latest available driver from the nVidia wedsite, and, as this is a pretty old card, if it still does not work right, try turning off ‘GPU tessellation’ in Options > View > OpenGL page.

-Pascal


(Jumichals) #12

Hi Pascal - thanks! That helped bring the lines back. The only small thing is that the lines (edges) of curved objects become choppy when rotating the view.

Also, in View>OpenGL, I didn’t see any option for unchecking ‘GPU tessellation’. I will paste a screenshot.
Let me know if there’s anything else I can do!
Julia


(Pascal Golay) #13

Hi Julia - ah, OK - that is V5 - that does not have GPU tessellation. I think you’re set. I don’t think there is anything to do about the degrading edges but you can try lowering the number in Options > View > Dynamic redraw. Default is 5 frames.

-Pascal


(Jumichals) #14

WOOPS - I didn’t realize I still had V5 open (to export my aliases) and I was drawing in that. Ignore my last comment - sorry!

I just drew the same thing in V6 and it looks beautiful.

Julia