Line Styles: Screen v. Print

Is there any way to get line styles to match on the screen and print? I had been told that using a layout would do it but here is a model in a layout:

and the same printed to a PDF:

The lines styles are no tth esame.

Generally you would adjust the line type scale in Layout to make it look right.

The view about is in a layout. The line styles look right in the layout but are completely different in the print.

Is it maybe a scale issue?

I am setting the scale. The problem is I am getting a different scale on screen and in print.

Try running “PrintDisplay” on the layout. This will enable line type scaling

I did that and it changed the display to like the print. However, when I change the line scale nothing happen in this "print view: as it does in the “display” view.

I’m not sure I follow, or maybe there is a bug that needs to be fixed. When printdisplay is enabled on a layout you should get linetypes that match your printed output. If not, that is a bug and I would need some help to try and figure out how to repeat this.

Here is a simple example. I:

Created a rectangle in a layer.
Changed the print color in the layer to black
Created layer
Locked
Enabled the Print Display.

I can then change the line style scaling and it has no effect in the print display (but does in the display mode).
Problem Layout.3dm (3.0 MB)

I had put this issue aside. What I am seeing is that changing the line style scale has no affect on the line style in print or in print display. I can see the line scale to 1 or 1000 and I get the same output (or display in print display mode)

Hi Miano,
Linetype scale is only used if if PrintDisplay -> PrintDisplay -> LayoutLinetypes=OFF.
If you toggle this OFF, then the it will be used.

1000 is a bit large, because if the linetype scaling is too big, then the line will look continuous. With most models, this is between 10 and 100.

Allow me to go into this in a bit more detail. Linetype scale setting scales the linetype in model space, and the scaled linetypes are displayed on the Layout, at that size. This may not be the best look for your model. If you want to make the linetype on the layout and print and display the same size, regardless of the the Detail scale, then you need to read on.

In order to understand the scale, let’s go basic with a 1=1 scaled detail.
If we measure the distance between the dashes, they are exactly the size defined by the linetype definition. If the PrintDisplay -> LayoutLinetypes=On, then the linetype displays in the exact sizes in the definitions.


Look at what happens if PrintDisplay -> LayoutLinetypes=OFF, the Linetype scale is 5 and the linetype definition is 5, leaving the linetype display to a product of these two number, or 25 mm. (this only works if the Details scale is 1=1. If it is not, then you also have to factor in the Detail scale and it is just gets more complicated.

A test file is attached. Open it and look at the Top viewport.
Let’s start in the Top viewport. Geometry is created full size.


The linetypes are applied to all the geometry. However, these objects will be shown at different scales, the larger plan at a smaller scale, and smaller objects at a larger scale. (My experience is with Imperial units, but in Metric units it works the same.)

On the layout, if the PrintDisplay -> LayoutLinetypes=Off, the Linetype scale is factored in, however, the linetype are generated in the model, and displayed on the layout. So, they look small on the large object, and big on the small object.

What if we want them to display and print the same size on the layout? Then you need to set PrintDisplay -> LayoutLinetypes=On, and the Linetype Scale is NOT factored in to how the linetypes are display. And this is what you will see on the layout, regardless of size and scale, the linetype size will be consistent on the sheet.

If you want your linetypes to display at a consistent scale, but you think these are too, big or small, you will need to edit the Linetype definition values.

Sorry this got long.
I have logged a few suggestion for the Options -> Linetype dialog that might help this issue in future Rhino.
Let me know if this helps.

Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA
Linetype display controls.3dm (98.3 KB)

Thanks,

I did not find the usage intuitive because the model space and the text scale independently. The drawings, text, and hatches do not behave consistently with the default settings.

Hi Miano,

Can you send an example of this? A 3DM file would be really helpful. You can create your own custom templates, which can take away the need for a lot of the monotonous setup of new files.

Scaling for linetypes, text and hatch are controlled independently.
This was suggested by beta users in the development phase of Rhino 4 & 5.
Rhino 6 & 7 really just carries these workflows forward.

If there is process that will work better for you, please send details and images. I am happy to write up a feature request for future Rhino.

Kind regards,

Mary Ann Fugier
McNeel Technical Support

I am referring to the general operation of Rhino.

If I draw something in the model space, include text, and include hatches, when I go to the model space (with the default settings) the drawing, text, and hatch as scaled differently.

You disable text scaling, the text and drawing scale the same in the model and layout.
However, if you set the hatch scaling correctly in the layout it does not appear in the model space.

I am trying to think of how it should work. I cannot think of a reason to have text scale differently in the model space and the layout. Maybe some others have such a requirement.

Now that it has been explained, it’s not a big program. It seems counter intuitive to draw text in the model then find it is huge in the layout.