Licensing problem

Hi all,

Any solution for this? I just installed Rhino 7 but I can’t get past the Licensing step as I get this…

Any suggestions? Thanks!

Hello - what operating system? Is the OS completely up to date?


Hi @pascal ,

It is a Windows 10 Enterprise; version 20H2; OS build 19042.804; experience pack 120.2212.551.0.; update KB4601382. The system is up to date, as well as my drivers.


Hi Leonel - are you able to click the X and close this dialog?



Yes I can close it and also click on two invisible buttons (around the middle) that take me to privacy and end user policy. I see the text of both policies inside the window but I can’t go back or do anything else.


Hi Leonel - can you please try starting Rhino in Safe Mode (Start Rhino in Safe Mode: Windows start menu, type in ‘Rhinoceros’ and look for the ‘Rhinoceros in Safe Mode’ entry.)
Does that allow the thing to complete normally?

Also, Leonel - is Windows using a dark theme or a custom color scheme by any chance?



I did have a dark customised theme. I reset the theme and restarted the laptop, then tried opening Rhino 7 in safe mode, the same result came out.


Are you using the latest installer for Rhino 7? Rhino - Rhino - Downloads If not I’d try that next. Another thought is if you have any special not recommended display scaling set for Windows. It sounds like the two links and the check box are there to agree to the licensing details but those aren’t being drawn for some reason in the window.

@brian may have an idea too.

I had this problem, my workaround is uninstall then with the latest download 7.3 start installing and hit the advanced cogwheel, change the licensing method to what you need and enter the licensing details , in my case zoo, thus i dont get presented with the blank licensing box after installation, not a a fix but a workaround

Hi @BrianJ, I am using the 7.3.21053.23031 (I think the latest) installer. I have checked that all graphic configurations of my windows are reset, so this might not be the problem.

Update: I tried installing 7.4.2159.01001 but it gives the same result

Hi @its, this seems like a good workaround. The problem is that I need to join a group account (my university) so it seems that I really need that window to sign in (the sign-in option is not available during installation).

Hi again! @pascal @BrianJ . The solution as @its suggested was to reinstall windows (I used the reset option, keeping my personal files). That got rid of the white floating windows everywhere!
Hope this can help others!

1 Like