LayoutPropertes: cannot change printer/paper size and save it


#1

I created a new layout, without entering any specific printer. So the Layout Properties popup window shows “none” for the printer and “custom” for the (paper)size. Changed this to my Brother printer and A4 paper size and clicked OK. No visible change to the layout, but deliberately choosing a “wrong” size (A5) shows that the layout updates.
Opened the properties window again, printer setting reverted to none and custom. The layout size is not affected at this point. Closed and saved the design file and reopened it, the layout is back to the default size and, not surprisingly by now, the printer settings are none and custom again.
Is there another way to save the layout sizes? Or set as a default at least?

Max.


Rhino 5 for Mac WIP Build 5E41w
(Brian James) #2

I think the ImportLayout command would help here but it appears to have an unimplemented dialog so I filed https://mcneel.myjetbrains.com/youtrack/issue/MR-2924 I then looked at saving a new template file with a layout in it and starting any new file with that template to control the layout defaults. It appears to work but the layout properties don’t match what the preview of the layout shows. I filed https://mcneel.myjetbrains.com/youtrack/issue/MR-2925 for that one.

@mary uses layouts much more than I do and may have some other thoughts too.


#3

Thanks BrianJ.
@mary: my main points are:
How can I change a layout paper size and make it stick?
How can I set a default layout paper size?

Edit: just to be clear: BrianJ talks about (and registered) bugs at importing layouts, I am talking about changing layout paper sizes in one and the same design file.


(Mary Ann Fugier) #4

Hi Max,

How can I set a default layout paper size?

The short answer is that you can not.
The default layout page size is dynamic. Rhino for Mac uses the last layout added as the default size. This becomes the Rhino default. I am not aware of a default setting or Preference that will control the page size of a new layout. @dan can chime in if I am incorrect. (Rhino for Windows uses the default sheet size of the default Windows printer, a different world.)

How can I change a layout paper size and make it stick?

You can reconfigure an existing layout to a different page size and have it remembered if you save the model. That should be remembered on that Layout page if the model is closed. The layout page unit always defaults to match the unit of the model. For example if the model is in MM the page unit will be MM. However, Rhino will convert the sizes to familiar units for you. This does not change the sheet size. For example in a mm model, we can add a layout that is 36"x24". Rhino will she it as 914mm x 609mm, unless I display the “inch” size equivalent 36x24.

Let me know if this is what you are seeing.
I do not see a bug here. Possibly a feature request for a default Layout page size. If you know that default is always the last page you added, that may be enough to take the mystery out of it.

Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA


#5

Hi Mary, thanks for your extensive reply.

This was my main point, and it was not happening like that when I wrote my opening post of this topic. But today I installed version 5.2.4. and it does save a revised layout, so I am ok.
I still don’t understand how Rhino sets a default size, mine seems to come out at A4 size every time, which is fine since that suits my printer. I will do some more experimenting with larger print sizes (if I can coerce my printer in accepting those, if only to create a pdf…) and let you know.
I am finding it odd that Layout Properties does not remember the source of the paper size, i.e. printer name and setting, I am seeing “none” and “custom” every time I open the properties window anew.

Regards,
Max.

btw. I did read your reply on History, but I need some time to study it.


(Mary Ann Fugier) #6

Hi Maxz,
It would be good to see a screen capture or a small video to show this.
Sorry but I am unable to repeat it.
Thanks again, Maxz.

Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA


#7

Ok here goes:
I am about to create the first page of the layout, so I clicked the +sign at the bottom of the LH panel, the “New Layout” window comes up and this is my input:

The layout page has been created, I typ the command LayoutProperties. A window “Modify Layout” appears

As you can see the size properties are correctly retained, but Initial Detail Count is set to 0, Printer to “None” and Size to “Custom”. If this window would reflect the Layout Properties as the command suggests, I would have expected to see “1”, “Brother DCP-152J” and “A5” respectively.

Assuming that it’s role was indeed to modify the Layout Page (although I would have expected a different command and a window with different input fields for that), I tried to change the input fields. Changes in “Initial Count” have no effect at all. Then I entered the name of my printer again, and changed the size to A4 and the orientation to Portrait. This does indeed modify the layout.

Max.


#8

@mary,
I mulled this over some more and found out that you can change the Width and Height values individually, which does result in a modified Layout page. Retaining the source of the original size would be pretty useless in that case. So I would suggest the following:

  • Change the command name from LayoutProperties to “ModifyLayout”
  • In the window, grey out the input field for “Initial Detail Count”

Max


(Dan Belcher) #9

This should be better in the latest RhinoWIP (5E41w). Please give it a try.


#10

Hi @dan ,

Judging by the amount of your posts this morning you have been really busy!
I have downloaded the new WIP, and tried Layouts again, but I am sorry to say that nothing has changed on the subject issue, other than the “Drafting”-palette now appearing in the top of the left sidebar.
When I click LayoutProperties, the field “Initial Detail Count” is still there, and changing the number does nothing. The rest works as expected.
I know it is a minor thing, merely suggestions for improvement. Forget my ramblings about retaining the paper size source, just look at these:

Max.


(Dan Belcher) #12

Sorry again for the slow uptake on this.

Both good suggestions.

Change the command name from LayoutProperties to “ModifyLayout”

Changing the name of the command won’t likely happen, but I think changing the dialog label to reflect the command that is running it is a good idea. Logged in RH-38339.

In the window, grey out the input field for “Initial Detail Count”

That makes sense. Logged in RH-38338.

Thanks!
-Dan