Layout text not updating on screen

I have a layout with text that I need to update with project info.

-Seems to always update the first time I edit the file, but if I need to redo my calculations and update those numbers the layout doesn’t show the updated numbers, even though when clicking on the text block it shows the right numbers, the text block itself still shows the old numbers.

-Has happened with multiple files, but seems random.

-Sometimes the layout turns gray and I need to close down rhino and re open the file for it to work again too. I already tried to lock/unlock turn on/off all the layers and haven’t had any luck on getting the layout to work.

My files were created with Rhino 5, but resaved with rhino 6 Mac.
current computer:
macOS Mojave
3.8 GHz i5
8gb ddr 4
radeon pro 580 8gb

Just updated rhino to Version 6 (6.25.20114.03572, 2020-04-23) about to see if it happens again

Trying to get a screenshot of both problems to post here.
ETA: This first problem (see attached picture) I am having, since I can’t print the background bitmap I place on the layout viewport, already went on the visibility and selected background bitmap, it shows on the preview, but when I press CTRL+P doesn’t show up.
So I place a picture on a separate layer that I can lock and turn on/off, however when I save as a pdf the file is quite big, about 18MB, vs 1MB when it was background bitmap on Rhino 5.
I found a work around, that turning the object transparency down to about 40% the pdf came out to be 7MB without losing image quality. However it worked for about 2 days, now it doesn’t. The print preview shows it being less saturated, while when I press to print it prints as if no transparency was ever set.

I got one of the first bugs I noticed. The gray layout. again, I wasn’t able to make it work by turning layers on/off locking/unlocking. The layout itself is in my “Design” layer. As you can see on the picture below, the print preview on the left show all the information that should print. But when I press command+P it only prints what’s inside of the viewing area, and nothing from the layout itself.


This might be a bug.
Can you provide a smallish file with specific instructions to follow that will repeat the problem please?
If I can repeat the problem here on my Macs, then I can file a bug report for the developers.


I sent you a message with a link to a file and some info.

Thank you!

I have some more info to share and maybe solve what is happening. My error or a bug.

Rhino 6 SR25 2020-4-23 (Public Build, 6.25.20114.03572, Git hash:master @ f35d7ded15ec317635ced435d8df84327397038d)
License type: Educational, build 2020-04-23
License details: Cloud Zoo. In use by: Manoela ()

Apple Intel 64-bit macOS Version 10.15.4 (Build 19E287) (Physical RAM: 8Gb)
Mac Model Identifier: iMac18,3
Machine name: Yrineo’s iMac
Language: en-US (MacOS default)

AMD Radeon Pro 580 OpenGL Engine (OpenGL ver:4.1 ATI-3.8.24)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB
Graphics: Radeon Pro 580
Displays: iMac (217dpi 2x)

Graphics processors
Radeon Pro 580 (8 GB)
iMac (2560 x 1440)

USB devices
Broadcom Corp.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
E-Signal: USB Gaming Mouse

Bluetooth devices
Broadcom: Magic Keyboard with Numeric Keypad
Broadcom: Magic Mouse 2

Third party kernel extensions (7.5.1) D0CC7B8F-1F62-33B1-BE6B-B5573D2A607B (38.0.17) 579C5BD6-37C7-304F-BA10-98BD515A104C

Third party plugins

Rhino plugins
/Applications/ “PanelingTools” 6.25.20114.1002
/Applications/ “Grasshopper” 6.25.20114.3572
/Applications/ “AnimationTools” 6.25.20114.1002
/Applications/ “IronPython” 6.25.20114.3572
/Applications/ “Commands” 6.25.20114.3572
/Applications/ “Snapshots” 6.25.20114.1002
/Applications/ “RDK_EtoUI” 6.25.20114.3572
/Applications/ “Displacement” 6.25.20114.1002
/Applications/ “Renderer Development Kit” 6.25.20114.1002
/Applications/ “Rhino Render” 6.25.20114.1002
/Applications/ “RhinoCycles” 6.25.20114.3572

It happened again, and my guess is that the Picture command is triggering it. This time, in a different file from the one this morning. I went back to top view and was going to add the picture to be the background, but just pressed ESC and went back to layout and it was gray.

Fairly new to me, computer. I might need to do one more OS update, but I had that problem before updating to Catalina.

Also, I downloaded Adobe Acrobat Pro, and I can now save as “smaller file” using the picture in the background.

What are the details on the image file you’re using?

Here is one of the images I used. It is a screenshot. Maybe image size too big??

It’s certainly has far more resolution than can be used as a texture for a picture.
I suspect you just ran out of VRAM.
Try reducing a copy of the image way down and see if that works better.

Ideally, you want the image as low resolution as you can go without compromising the final need for it in a print.

I’ll try that next!

I am back to square one on ideas. This last time the layouts went gray on me I didn’t have a background bitmap or a picture in place. It was all lines and some hatch, no 3D either.

Now, here is the text glitch, the only way to fix it is to create a duplicate or start a new text. See attached video


This might be related, it might not.
It’s a long shot.

When you’re in that Layout, without a Detail current, type the SetDisplayMode command.
It should be “Wireframe”. If it’s not, change it to Wireframe.

it is wireframe on the layout and on the detail.

My last “Hail Mary” suggestion is a PLIST reset:

yup, did that already, and rhino is up to date too.

The text problem rarely occurs though. But it is there…

If you can come up with a command sequence that is likely to repeat it, we’re interested.
Without a repeatable problem, we’re stuck without a chance of a fix.

I have a template file, (all design and other text seen was there, file was created with Rhino 5 Windows, it had been saved as Rhino 6 Mac already), What I did on this case today was:
Open File>Open Layout>Change text (didn’t update)>Close File
Open File>Open Layout>Change text (didn’t Update) recorded and sent here>Option+Drag> Changed copy (updated)

Thinking back on what I wrote: Could it be because template file was created on a Rhino5 windows?

If it’s been opened and resaved in V6, then it’s a V6 file.
If that has never happened, then yes, that could be a problem.
Annotations changed dramatically between V5 and V6.