Rhino 6 not printing layout area

layout-printing

#1

RHINO 6 is suddenly not printing at all.

I have tried both the Rhino PDF maker and using Adobe but it makes any difference.

I have ticked and unticked annotation scales I’ve gone through all the print options I can think of. Raster Vector all sorts, display mode, printed mode, on screen.

In the print preview, the model comes up as missing components.

The files come up as 0 in size.

I have been using layout and am at the moment putting several views on top of one another to achieve my end goal of having clear edge lines and hatches.

My computer did run an update this morning but it has worked since then.


(John Brock) #2

Is you system waiting for a reboot?
It sounds like some Windows processes are not loaded.


#3

No John. I have started it up twice. I have a bootcamp system so I started both Mac and windows.


(John Brock) #4

Okay.
It this problem unique to one file or does a new simple file (like a box or a circle), have the same problem?
Does Rhino print from a normal view?
Raster or Vector?
Does the print preview show anything?


#5

Hi John

Sorry John
It works 1st time when I restart rhino and then the second time it stops working.

Once I go into my main drawing and try to fiddle it stops everything from working.

Just tried it on someone else’s system and it worked fine.


(John Brock) #6

Any chance you’re running any extra plug-ins?


#7

The print preview has missing items, mostly everything in paper space.

I don’t know if I’ve over complicated it all, I have 3 layers on top of on another, shaded, hidden and a modified pen mode.

But I was using this before till a few hours ago.

Issue is that I have’nt been able to get my Visual arq hatches to work.

So I don’t know if its a visual arq thing.

My Varq problem is that hatch patterns don’t resize properly in layout for non VA objects.

If I set hatch patterns for objects in the object properties-section properties tool panel they don’t scale correctly from one layout to another.

I have ticked the “resize hatches “ in the rhino options - hatches.


#8

I have a bunch of plugins but disabled several, evolute, elefront Im not sure if section cuts and Varq can run together.


(John Brock) #9

If it were me, I’d disable all of them temporarily, restart Rhino and see if you can get it to print correctly two or three times in a row.
If yes, the problem must be one of the plug-ins so you can systematically enable them until you find the culprit.
If it still screws up without them, then you know it’s not a plug-in.
At that point I’d try starting Rhino in Safe mode and see if that works better.
That’s not a solution but it might help narrow down the possibilities.


#10

ok Ill try.


#12

Hi John
I couldn’t follow the safe mode instructions @ https://docs.mcneel.com/rhino/5/help/en-us/information/startingrhino.htm

But I ran the start rhino 6 in safe mode command it gave me an error " this document cant be opened in safe mode" So I said ok and it started anyway.

My plugins seem to be loaded so I have no idea. Anyway, it seems to print now.


#13

ok finally figured out safe mode in Rhino six. But when I started it in safe mode it crashed!


#14

Did the crash dialog pop up, and if yes, did you send in the report?
Also, can you paste the result from the Rhino SystemInfo here?


#15

Rhino 6 SR8 2018-8-28 (Rhino 6, 6.8.18240.20051, Git hash:master @ d037927543424e8b3ce54e46b435866178a6349c)
Licence type: Commercial, build 2018-08-28
License details: Cloud Zoo. In use by: pretorius.sean ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-OVHIKFN

AMD Radeon R9 M370X (OpenGL ver:4.5.13476 Compatibility Profile Context 22.19.170.1536)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.50
Driver Date: 7-20-2017
Driver Version: 22.19.170.1536
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Users\SEAN\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot7RhinoPlugin (486807a0-d332-4669-8086-e0497d91acd5)\1.6.0.0\KeyShot7RhinoPlugin\Rhino 5.0\KeyShot7RhinoPlugin.rhp “KeyShot7RhinoPlugin” 1.6.0.0
C:\Users\SEAN\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\ElefrontProperties.rhp “ElefrontProperties” 1.0.0.0
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.6.14.669\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\Tibidabo\VisualARQ.rhp “VisualARQ”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.8.18240.20051
C:\Users\SEAN\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SmartTagsForRhinoV6.rhp “SmartTagsForRhinoV6” 0.0.0.1
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.4.17.851\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”


#16

And yes I did.


#17

I also cannot print wire frame. I have switched off all the plugins and still have missing lines. @John_Brock you personally advised me to move from parallels to boot camp and I have tried but this is really not working. After 2 years with Rhino I feel like I made a terrible mistake in leaving sketch up behind.


(John Brock) #18

SketchUp and Rhino are intended for very different uses.
SketchUp is a mesh based tool intended to quickly and easily model something and generate convincing images to sell an idea. It uses gaming display technology and really has no equal for that use.
However, once you win the job, you need to start over with some other technology to make models accurate enough for manufacturing, as the SketchUp mesh model generally isn’t smooth enough and accurate enough for manufacturing.

Rhino is a NURBS based industrial design surface modeling application. It is intended to make models accurate enough for manufacturing. Rhino would be a good choice as a follow up to SketchUp to make the production models.

Starting with Rhino to model and render to sell the ideas, is not nearly as fast as SketchUp.


#19

Sketch up printed my work. Rhino 6 does not. I am beyond frustrated, I have tried all this time swapped entire system downloaded plugins, unloaded plugins and really it just wont print.
Why will rhino not print wire frame, why do I some days have 13 crashes. I think rhino 6 is just not ready for a bootcamp system.


#20

a simple block

asimplebox.pdf (5.6 KB)

Have a look this is rhino 5. No hatches.


#21

@John_Brock I have isolated the bug. When I change the print resolution from 600 dpi in the print setup to anything higher 2000 DPI (which admittedly is too high) the printed PDF’s from layout show up empty. Even after I reduced the dpi and tried to print again. When I reboot rhino 6 it works again perfectly.

I obviously don’t need to go that high but that was the problem.

Then the problem was also intrinsic to a template I create. So every time I used the template my work wouldn’t print. Attached. I just no longer use this template.

Those were my issues. I think I’m mostly sorted now.

SEANSVA.3dm (5.3 MB)