Layout dwg Export including detail views

unhandled

#1

There was an earlier subject reagarding layout export that reamained unsansvered.

In general I think the layout works fine but when sending drawings to yards they often need to have dwg drawings. If export to dwg is made from layout view/tab only the information added to the layout tab itself is printed. Not the information in the detail views itself. I.e. if you export a drawing where measurements is in made in the layout view only the measurements and drawing head is exported, not the details in the detail views.

Mainly this prevents to be able to use the layout view when working with other companies since it anyhow needs to be redone in a dwg program if you are not interested to send complete models since normally a pdf file is not enough in production.

Is there any workaround for this? If not, is there any thoughts of improving this?


(Dale Fugier) #2

@Lowell, can you look into this?


(Pascal Golay) #3

Hi Niklas- I am not sure I see what you see yet… from what I can see both dimensions (added in an active detail, and added in the layout space) are visible in the layout view when the dwg is opened in Rhino, but only the 3d detail added in the active detail is visible in the model space- is that what you see? Also, I see the dimension added in layout in Rhino changes its value when the dwg file is reopened in Rhino… That looks buggy to me.

-Pascal


#4

Niclas, It would be great for Rhino layout tabs to show up in an exported Autocad/dwg file, but this seems would be difficult to implement. Isn’t this like saying you want Autocad layout tabs to show up in Rhino? That would be amazing too of course.


#5

I am not syaing that the tabs should show up in Autocad if you read carefully. From my point of view there is no need to get the tabs to be exported but in general (or with all the yards I work with at least) we send a pdf drawing that is the original and then also a dwg file wich contain editable data.

This does not need to be made that all tabs shall be exported but if the layout is printed to pdf the drawing with drawing head shown correct. If you try to print (or rather export when it comes to dwg) exactly the same (to have as editable file) i.e. you make an dwg export, marking all the content in the layout tab, only the measures etc. will come in the exported file. Not the content from model tab/detail views.

Easy to test I would say by in the layout tab make a detail view of some content and also write a text in the layout, print to pdf and try to get the same result (still in layout tab) by exporting to dwg.

How I use it is that I Make2D from a 3D object and the make detail view on the layout. In the layout text, measurements and drawing template is added. By that there is no 3D content in the detail views.

Once exported to dwg it does not matter, at least for me, if the drawing does not show up in the dwg file as model and sheet (as in Autocad). It can be all content in the model space. But as it is now the basic content is not included only the text, measurement and drawing head.


(Lowell Walmsley) #6

Are you using “EXPORT” and not “SAVEAS” to go from Rhino to AutoCAD?


#8

Oh dear. I can’t believe I haven’t been using the save as feature. I’ve been so wrapped up in export land for so long. Lowell thanks for opening the curtains for me.

and now I want to know, is there a way to open dwgs with all of their layout tabs??


#9

Thanks Lowell, defenitely solves some of the issues and also bring along what seemed to be inpossible. However once tested it open up others questions.

It is splendid that all the tabs etc. goes along. More than could be hoped for.

When I have a large 3D model of a vessel in 3D, have made some 2D drawings with Make2D and added some layouts and uses command “save as” the complete model including 3D content is saved. Even though everything else is hidden or on non visible layers and only what is on the Make2D layers + layers used on layout tabs visible.

Is there someway to control that only visible content, content only on certain layers or what ever shall be saved when using “save as”?

Otherwise the Rhino file needs to be cleaned (delete 3D model) or the dwg file needs to bee cleaned in all layers with the risk for stuff you do not wan´t to give away goes to other people

Do you have any tips for this as well?


#10

Niclas, when I saveas to dwg, my hidden stuff doesn’t transfer over to the dwg. The locked objects do though.


#11

You mean hidden with the “hidden command” or with non visable layers. Non visable layers includes in the save as command when I test. I trying to find a workaround…


#12

yah. hidden objects. that would be a nice feature, an automatic cleaning out of the non-visible items.


(Lowell Walmsley) #13

Hidden objects get written by SaveAs too. You can see them in AutoCAD with the UNISOLATEOBJECTS command.
That may not be convenient for you, but its the way it is.
I don’t know of a way to send only some of the objects in your file but still send layout viewports to a dwg file.
As I’m looking at this, I see some problems related to annotation scaling in Rhino.


#14

Ok, Thanks a lot anyhow. Now at least most of the issues is solved. The rest is more of a cleaning job to get rid of data not to send along.


#15

Lowell,
You mention that there are problems with annotative layouts.

I have been using SaveAs to bring drawing layouts into AutoCAD. If the dimensions were made in the layout referencing a model when opening the drawing in AutoCAD the paperspace dimensions are no longer scaled they are instead measuring the distance on paper that the dimension is representing, without accounting for the detail scale. Is there a strategy which will prevent this from happening?
Thanks,
5chmidt


(Lowell Walmsley) #16

The only strategy for doing something even similar that I can think of is to make the dimensions in paper space.


#17

I have created a number of sections and details using the clipping plane tool within Rhino.

It seems these clipping planes do not translate over to AutoCAD.

I do have these clipping planes on a turned off layer within Rhino, could this be the issue?

Thanks

Pete


#18

Yes, It definitely needs to be improved. One of the most common way is still the dwg and pdf format towards consultants.

Clipping planes should be exported into vector graphics too. It is nice quick tool for creating sections however the program does not export it on layout. Batch export for Layout DWGs would be also essential.


#19

Just to add to this list:

  • Would be great if on/off in Annotation layout would work when saving as dwg.
  • Also ‘hideindetail’
  • And last not least the text I have in my titleblock (which is a block object) does not show up correct

(Lowell Walmsley) #20

Those layout visibility things are on our list of things that would be helpful. They just haven’t made it to the top yet.

As far as your title block text, I can’t tell anything about what’s going on without an example file. A simple one is way better and quicker to analyze. I’d be happy to look if you post something.


#21

Hi Lowell,
here comes another one. I also do a lot of combined pdf/dwg export work for customers.
All those drawings contain embedded images and I was able to establish a workflow which allows
for a) exporting all possible Layouts with print to PDF and b) via ‘Save As’ also to DWG-format.

There is only one challenge that I have to struggle with concerning the ‘display order’ (… and only when writing out DWG-files via ‘save-as’) Everytime I have my images in the same c-plane that I have the rest of the drawing elements in, PDF has no problem with the drawing order and exports correctly. When I then try to ‘save as’ the drawing file together with the embedded images, the images will obscure the rest of the drawing elements.
So I choose to move them down a bit below the c-plane and to also use the ‘send to back’-command to be on the
save side when writing out the DWG-file. This almost everytime works, when exporting the DWG-file directly after having
moved the images below the c-plane. If I then have to do any further amendments, even the slightest ones, the drawing order seems to get lost again and although the images, or the surfaces, that ‘carry’ the images are sited below the c-plane they will again obsure the rest of the drawing (area which they cover). This way I will always have to go back
and move the images a little bit (does not matter if I move them up or down btw - as long as I keep them below the c-plane), then ‘save as’ again and everything is fine. Could you please look into this ‘drawing order’ thing. It’s realy annoying, when you have to do lots of comples drawings with embedded images per day. (working in the mannequin development - just to let you get a clue, as to why so many images are used in those drawings) THX in advance Klaus