Layout/Detail - Lines appear to be interrupted


#1

Hi,

I want to understand if this is my fault or it is something that appears to be a bug.

I have a 3D model, and I made a Clipping Plane.
Now, I place a detail in a layout sheet, and it looks horrible. The silhouettes lines appear to be interrupted.

I am trying to “skip” the part of Make2D, and then arrange my lines to different layers, so that when printing, I can have thin and thick lines.
Can this be fixed? It is pretty important to have faster drawings, using this method.

Thank you.


(Pascal Golay) #2

Can you please post your file here, or if confidential, send to tech@mcneel.com?

thanks,

-Pascal


#3

Have you tried making the image larger than you need, and then downsample it?


(John Brock) #4

That looks like a screenshot and not a print. I think you’re seeing a lack of antiailiasing.
Try printing it or printing to PDF and see how that looks.

My guess is the prints will look fine.


#5

lines example.3dm (1.6 MB)

Hello again

As you can see, it does everywhere. I noticed that in most of the cases, there where you have arches, or fillets, it does this. Also, if I print scale 1:1, it doubles or triples the lines… and that I cannot send to the customers.
I am forced to apply the Make2D command, and select manually the lines, for thick and thin…

Try the model, and see for yourself. The detail from the layout it is set with the PEN viewing option.
I tried to make my own, but had the same results…

The printer prints exactly what you see. Either if it is just a Side view or a Clipped view. The results are the same.

Thank you,

T.


#6

The thing here is that the pen mode, which you are using to try to by-pass make2D, is a screen display mode, whereas make2D produces vectors.
You will likely get a much cleaner result from a vector drawing, because it doesnt depend on your display for its printed output.

Depending on what your final output is going to be, you might be able to get a good enough result from pen mode by trying the following:
Firstly set your anti-alias to the max your computer can handle (options/view/openGL). Then, simply print the screen with the viewcapture-to-file comand, and follow up by assembling the images you grab in photoshop or other related software.
You might also print from rhino to an image file - set the resolution to a high number like 800 or 1200.
Open the image in photoshop, reduce the image to something acceptable, run auto-levels @ 50%, maybe un-sharp mask and then print or otherwise export the image from there.

Attached is a make2D pdf of your example file, and an image that was treated as above.

test_2.pdf (5.3 KB)

cheers
rabbit


#7

Thank you for your reply… but think about from this point of view now.
Following your steps and the time it takes to achieve a good result (not mentioning I need to get a 2nd software)… orrrr…
Time spent with Make2D command and then manually putting the lines into thin and thick layers.
For efficiency I think second one is better… but then I get to where I was already. So nothing is fixed.

Thank you again, but this does not solve the issue.

Either to add to a wishlist, that it is best to have something that allows the user to have a detail, in the Layout, which grants you a view of the 3D model, that has thick and thin lines… Thus, when I will make modifications to the model, I would not have to create again the drawing… and only to print the sheet again.

T.