Make2D and Clipping Planes

I was trying to use Make2D and clipping planes to very dimensions.

In the attached, I have a part and a clipping plane. When I run make2d on the part with the clipping plane, I get many lines that do not show up in the rendered version?

Is this a bug? An operator error? A misinterpretation of how things are supposed to work?

Problem (1.4 MB)

Hi -

If those are the only possibilities, it would have to be the latter. This is currently be design but there is a feature request for Make2D to check the Show fills property of clipping planes in the display mode that is being used. I’ve added your vote to RH-33007.

1 Like

+1 vote from me as well. Would love to see this.

1 Like

Is there a way to make 2d for JUST the clipped geometry, as in not show geometry behind the clipped plane?

I feel that this would solve a lot of these issues. For reference examples look at SolidWorks and those drawing section options. This “show section cut only” is an option there and is often a better solution.

Hi Kevin -

That sounds like something you could get with the Intersect command.