Make 2D leaving gaps/missing lines

The Make2D option seems to be leaving out some lines.

Very simple example:

As shown in the example, a line that is present in the model is incomplete. This one line is of course easy to fix and does not cost a lot of time, but some other more complex models are missing a lot more lines.

Cheers

Peter

1 Like

Make2D has done this since Rhino1.

What I do is alwasy make 2D WITH hidden lines and then check if any of the lines that are should be visible are on the make2D hidden layer. And sometimes it just doesn’t manage to calculate the silhouette. But id say that 90% of the missing lines are on the make2D hidden layer.

Well the problem with that would be that the objects are so complex internally that it would be a lot of work to find out what lines you need. At least the way you explained it sounds as if I would get all the lines from the object in 2d.

Nah, the hidden lines are on a different layer, so you just turn it off, locate where the missing info is, turn it on and selects the curves and moves them to the correct layer and deletes the rest. Quick and easy.
Just try it.

I’ll give it a shot later today, I’m working on some renders at the moment. The make 2D takes around 1.5 hours without hidden lines at least.

Hi Peter,

To speed up the Make2D time you can

  • 1: first increase file tolerance
  • 2: Run Make2D
  • 3: set tolerance back to working value.
    Larger tolerances can reduce calculation times quite a lot!
    Of course this is of no use when you need very precise Make2d results yet if this is for print, or visual reference, you can get away with quite a large tolerance. (just test on smaller files or portions first to get acceptable tolerance settings)

To set tolerance:

HTH
-Willem

1 Like

Thanks for the tip Willem, Holo,

I’ll be continuing on this later today i’ll post my findings!

I’ve tried using hidden geometry too, but this just costs too much rendertime.

But in the first place, it would seem this is a bug rather we are working around rather then something that is intended.

Hi Peter.
The hidden linebug is absolutely a bug. So is the faulty contour that happens every now and then.
But the tolerance is not a flaw. Calculating at higher precision just takes more time.
I would agree if you think it is a flaw in the command that it doesn’t have tolerance built in, but it is not a bug.

Regarding hidden lines calculation, it should not take any longer at all, as Rhino has to calculate all the lines and filer out what is visible anyway. I have not tested this, as logically it should not make a difference. Have you tested that?

Yes that is what I meant, the missing lines is the bug part :wink:

The tolerance vs time is logical. I’ll be doing some more 2d conversions soon so i’ll notice soon enough in what proportion the tolerance will lower make2d time

This actually worked for me, I set absolute tolerance to 0.00001 and all of my lines got drawn. What a relief since I was getting ready to redraw all the lines. Thank you.

3 Likes

Hero!! :raised_hands: