Layer color not showing the picker

When I click the color chooser on Layers panel nothing happens.
Not sure if this has been reported already but didn’t find anything on forum
Running Rhino BETA (7.0.20273.15003, 29/09/2020)

Any chance it’s on a 2nd monitor or behind your modeling window? I cannot reproduce it here.

No way, as I hit the color nothing happens.
The only way to change layer color is through ColorPicker Plugin from McNeel.
If I set any other option rather than Default I get a Color Picker.

can you do a screen recording and show us what is happening?

before you do that, run help>check for updates.

Ok, how do you prefer the screen recording to be done? I remember there was some command built into Windows 10 but cannot recall it.

I use snagit or a gif recorder… there are several free ones out there.

Here you can find link to the video.
This was happening already before installing ColorPicker plugin.


have you updated to the commercial release of v7? Are you still seeing this issue?

Not yet! didn’t know Rhino 7 had been released :grinning:
Downloading now.
Tested, but I am having the same issue, Default Color Picker is NOT showing.

The V6-style ‘default’ color picker is no longer available in V7. You now get the multi-system color picker.

Hi, the point is that I DO NOT get any Color Picker when I click on the color to change it.
Is it possible I am the only one experiencing this and there is no way to fix it?

this is really puzzling.

try this-
go to add or remove programs in windows control panel
find rhino, single left click on it, then choose modify then repair.

let it run then restart your machine.
then restart rhino
any better?

if not call us and lets take a look at your machine-
Technical support (206) 545-6877 8-5 pst

tryed your fix but still not working.
I am in Italy, so calling maybe not better option?

ah… call our barcelona office in that case-

Phone: +34 933 199 002

still having this issue which prevent me from adopting Rhino 7.
Anybody around having problem with this.
Looks like I have to reset my PC and have to reinstall everything?
This is weird…

call our Barcelona office, they can help-

Thanks again @theoutside
I contacted technical support already but no fix has been given so far.

Some update about this:
-> Looks like another user is experiencing this bug?
-> I just tested the new Rhino 8 WIP where the color Picker works nice.

Color Picker is working in Rhino 5/6/8 and in all other Windows Programs.
No way to appear in Rhino 7. I tried already to repair or reinstall from scratch Rhino 7 but with no success.

Maybe @dale can help at this? I suspect this happened because I had installed his ColorPicker Plugin

As I told already, this is preventing me from upgrading to v7.


Is it still installed? (Look in Options>Plug-ins)

Currently I can see ColorPicker in the plug-in list but is NOT enabled.

Tried also to completely uninstall and install again trough PackageManager, as well as many other checks suggested by McNeel’ Support Giuseppe Massoni.
We found no fix so far.
Currently If I enable ColorPicker all options, apart from the default one works.

Nonetheless I just want get rid of ColorPicker and have default chooser in order to have transparency.

Sorry we haven’t found a solution for you yet, the issue is that we’d need to reproduce what you are seeing to fix it. I just tried installing the latest ColorPicker plugin (version 6) from and with it enabled or disabled, I can’t reproduce this issue but I have some ideas for you to try…

In your video you showed the ‘Office’ version of the ColorPicker. The ‘Default’ option for that plugin/command gives you the same default color picker as if you didn’t have the plugin installed and enabled. Does that work for you if you enable the plugin and use the Default command line option for ColorPicker? You’ll need to enable it in Options > Plugins and then restart Rhino 7 to try this if it is not currently enabled. The second thing I want to try if that doesn’t help, is if you can try holding the Alt key down when you left click the color swatch.