BUG: Color picker Rhino 7

Hi,
it seems like the new color-picker is not working. I just wanted to try the possibilities for the new hatch features.
(Running 7.0.20309.06004)

-f

Hi -

Did you get this solved?
-wim

hi,
no it is still not working. It the color picker shows only gray, and some time some random colors, where i don’t know where they are coming from.
(now running on 7.1.20343.09492)

@wim Eyedropper doesnt work either. At least no how one would expect.

For example I may have set a custom color for a layer at some point. So now I have related layers that I wish to have the same color set for. You’d think I could click on the color swatch, click on the eyedropper, move the mouse over the layer panel to the layer in question and click on the color of the layer I wish to copy. However the eyedropper once clicked is utterly incompressible as to what exactly it’s stealing the pixels from. It shows a zoomed in view of something, but it does NOT correspond to where I think my cursor is, and in actuality I have NO clue what exactly it’s getting it’s big blown up pixels from. Can’t find any docs in the online help or command help that even touch on how to use the eyedropper, but it certainly doesn’t behave the way it does in pretty much any other application (including older versions of Rhino) does. It’s either broke, or has changed (and certainly not for the better, since 90% of the time when I do want to use it, it’s to grab a color I’ve already assigned to something elsewhere.

im also having problems with the colour picker, in my case i cant get it to appear at all. I bought Rhino 7 in December, im sure it worked at first but it doesnt now. Ive tried resetting to defaults for everything, and have just installed 7.2. But its still not there.image If i right click on the layer colour box, then go set properties>colour, nothing happens.

Hi,

From your screenshot it looks like you are on Windows not Mac. Check for Windows updates and then check the update history log as well for any failures.

yes sorry should have said. New to all this

Hi Mark,
I am experiencing the same problem!
Please see this thread.
This has not been resolved yet, contacted McNell support already but no fix has been given yet. This is preventing me to upgrade to Rhino 7

I replied in your original thread.

have checked and everything up to date and no failures. Have installed from food4rhino their colour picker pending bug fix, but that doesnt work either!

good new i renamed the two .xml files as suggested on another thread and it works now. Thank you