Laggish polyline (same goes with other tools)


here is a video:

By going into other views, sometimes it works, but it’s still lagish, and doesn’t work well, while in the perspective view, it doesn’t work at all

By exploding and hiding the faces that I’m not gonna use, there is the same experince, the polyline doesnt work (btw same goes with other tools)

I’ve read in other threads that it might be a gpu issue, so I’ve opened the rhino setting/view/opengl

Hello - can you save a minimal model with a view where it is not working and post it or send to Please include a link back here in your comments.


is it ok if I do include only a part of the model?
I’ve already checked and by exporting the part and reimporting it gives the same issuebrokenthing.3dm (259.2 KB)

Hello - so, if I understand the clip, the lag is in getting Osnaps to register, is that correct? And just to make sure if you open the file you posted, all by itself, no import to another file, do you see the problem? (seems fine here).
Please run the SystemInfo command in Rhino and copy/paste the results here.

Also, I see the grid is very large compared to the object - if you have grid snap enabled, it would mess with the relatively tiny Osnaps.


I’m not entirely sure of what you do mean, but the lag happens with both osnaps activeted and disabled (with every tools, not just the polyline)

yes, if I do open the file by itself, the issue is still there, but with the file that I’ve posted, it’s less present than the original model, but it’s still bad

the issue is less present with geos that are less “heavy” I think? I mean if I go far away from the geo, create another geo, as long it is simple/a primitive object, I have no issue, but when the complexity of it increases, it starts again to lag
I don’t known if it’s related, but maya (autodesk) has a similar issue on my system, when the geo starts to get heavy, tools start to break apart

Here are the results of system info:

Rhino 7 SR2 2021-1-21 (Rhino 7, 7.2.21021.07001, Git hash:master @ 96ff97351fbdf5d2acdeaf781aea1577f2ff60f7)
License type: Evaluation, build 2021-01-21
License details: Stand-Alone
Expires on: 2021-04-24

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2070 SUPER (NVidia) Memory: 8GB, Driver date: 4-7-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.92
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-7-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.2.21021.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”


Thanks - I do not see anything that leaps out at me in the system info - I guess I would update the NVidia driver, it is getting to be pretty old. I see nothing like what you show in the clip, here.


1 Like

I’ve tried with the more recent drivers for the rtx2070s (both studios ones and gaming ones), and the issue is still present
also I’ve tried with ddu

EDIT: retried to reinstall the drivers, this solved the issue
I don’t know why before it didn’t, but now there is not anymore that laggish problem, so the issue is solved

1 Like