Lag when selecting multiple objects Rhino 8 WIP

I’m having noticeable lag when holding shift and selecting multiple objects. It takes 2-3 seconds for the objects to show as selected after I click on them. Windowing and crossing are not affected. It has persisted through the last 3 releases. Is this a known issue?

I can not duplicate that problem using your instructions.

Please run the Rhino SystemInfo command and post the results.

Does this happen on all files, only on huge files, etc?

Selection Issue System Info.txt (3.1 KB)

This has been happening to me in files with many objects and few objects. This is happening to my colleague as well.

1 Like

Your SystemInfo says you’re running 3 monitors.
Does it make any difference if you start Rhino using just the built in laptop monitor, or 1 extra monitor, but not all 3?

Also, it looks like that file has a lot of extra stuff in it.

Run the New command and see if a new with with “No Template” is faster:

The video file only has the four curves pictured on screen. The additional layers are a part of a template we use. I used just the laptop monitor and I no longer had problems selecting. I tried “No Template” with three monitors and I no longer had problems selecting. Please let me know if you would like me to try something else.

I have the same problem. I use two monitors.
Never had this kind of problem with Rhino 7.
I use “Small objects, millimiters” template as I always use(d).

:: Gian

This issue has persisted with me through each WIP when I use my custom template.

Maybe post your template file so someone could have a look at what might be causing it.

Jewelry Objects Template.3dm (1.8 MB)


In my case I don’t use a custom template, I use one of the default templates (“Small objects millimiters”) and it happens anyways. I didn’t try with other ones as this is the template I always used, without customizing it.
It happens with all the files I am working on.

Only possible suspect: they are all files I began in Rhino 7 and now I opened them in Rhino 8 WIP…could be a problem?

Sorry: the sysinfo log I attached before was from a wrong instance of Rhino (an instance of Rhino 7). I deleted the wrong post and I attach here the correct sysinfo (Rhino 8 WIP)!
Sysinfo.txt (2.5 KB)

Try updating your display driver. It is over two years old.

@davidcockey The installed ones are the last available for that video card. I’ll attach the model as soon as I’m back to my studio.

What about @dalvarez ? Still happening to you?

@gian New driver from 2023. No guarantees that it will make a difference.

1 Like

Thank you @davidcockey !

Sorry if I missed them but my last check was in december and I didn’t find anything new so I lost my hope. :slight_smile:

I’ll try and let you know.

Hi @davidcockey

I use Rhino 8 WIP on three totally different different machines and they all seem affected by this issue, in particular when models start to be populated with many surfaces and solids. Not enourmous models but, let’s say, working with just three or four solids the problem is not manifesting.

Unluckyly I can’t share the exact models where the issue happens, as they are works in progress for my clients and they are still under industrial secrecy: they are just table lamps, nothing “militar” o “governative”, but clients don’t like their new projects are spread around before being in their catalogue ,of course.

Anyways, I followed your advice and installed the latest available video drivers on ALL the 3 machines in my studio:

  • DELL M3800 - NVIDIA QUADRO K1100M (Mobile Workstation)
  • MS SURFACE PRO 7 - INTEL IRIS PLUS (Tablet/Notebook)
  • DELL T7600 - NVIDIA QUADRO K4200 (Desktop Workstation)

In the next days I will be testing thoroughly on all the three machines and give you some feedback!
In you have any other clue, meanwhile, I’m here.


:: Gian

Hello @davidcockey

I made some tests with updated drivers on two of the three machines I use: the DELL T7600 (desktop) and the DELL M3800 (Laptop). The issue still happens. I tried with multiple files I am working on.

One new thing I noticed: it start to happen NOT immediately, but after a while I work on the models. When the file is freshly open it seems not to affect…

I will keep on monitoring the situation but it seems very strange to me.

Another strange thing: when, after selecting the first object I select a second one, if I move the camera while Rhino is “thinking” (I mean it’s lagging, not highlighting the object) appearently the lag is unblocked and the newly selected object is highlighted.

I don’t know if this can furtherly help .

I have had the same experience. The selection lag gets worse the longer I work in a Rhino session.

1 Like

Further info on my side: the file I work on most frequently in these days, that is affect by this issue, has a total of 150 polysurfaces (composed by 2553 surfaces), but the lag happens even if almost all surfaces are hidden and I work only on 2 surfaces (spheres) and 1 polysurface (composed by 16 sufaces)
So not very complex, I reckon.