Kiwi3D Deform Model issue in both Rh6 & 7


I have some issues even when I ran the example files. Please see the error message below. At first, I thought it was because I failed to install the plug-in correctly. So I followed the preview post " Kisi3d on rhino7?" to solve the issue. But the same error happens again on both my Rhino 6 and 7. I tried it a couple of times both using the .rhi install file and install them manually. Any thought on this issue?

  1. Model is not solved or Model-Input has changed, but Analysis has not been updated!
  2. Object reference not set to an instance of an object.

Thank you,


the first issue is only a warning. It tells you that Kiwi found an old data base / results that you generated before. It uses those result which may not fit the changes that you made in the current file. So if there were any changes made, it reminds you to rerun the analysis.
The second issue is a bit more tricky. Is it the original file or are there maybe already some changes (maybe you can upload the file)? Did you try to run the analysis?

Hi Anna,

I did. I ran it several times. But it all came back the same. I was able to run the analysis on my old kiwi3D file. I suspect it is due to the text file already exists. But when I run an analysis from scratch (meaning no text file yet), the error message will come up. It is the same when I run the example files too. I noticed after I ran the solver, it will generate the text file like below. But the problem persists. I also notice it only generates a text file, the folder does not have .georhino.txt, post.res, _restart_file.dat files. Is this why?

Thank you,
Bo (15.6 KB) FormFinding.txt (16.2 KB)

that is really strange. can you check if you can plug in a deconstruct model after the solver in order to check if the model was generated? Furthermore, did the shell window appear? You can also check the out.log-file if, when and how far the analysis ran. If you have Feierabend! in the end, at least the analysis of the solver was successfull.

I found out why. The latest Microsoft system update changed my folder setting into read-only. It caused the issue of generating the out.log-file and other text files. Thank you for all your helps.