Issues with the DOCUMENT LINKS component

I am using the rhino inside Revit plugin and I am getting issues with the “document links” component. I am using geometry from a referenced revit file in my workflow.

Sometimes the component doesn’t work and it gets red, saying the document is a cloud document. But sometimes it works, and also I have tried to load the component in non-cloud documents, and I get the warning as well… looks like a bug. But maybe there’s a solution to make it work consistenly?

Hi Ish, Can you provide a screen shot on how you are using the component?

In 1.4 last week there is a fix that deals with a revit api name change that may be related to your issue.

Thanks for reporting.

1 Like

I was about to show you the screenshot of the error, but now after opening up my pc its working ok again…

I keep getting this weird behavior when sometimes works and sometimes not… and the files are the same all the time…

Ok this morning I opened the document again and now I got the error:


Try expanded your ZUI on the Links component (small plus sign on your screen shot above) and feed in the active doc first, then select the Doc you need with a Value Picker component.


I tried and I still got the same issue (any more thoughts?):

What version of Rhino.Inside.Revit are you in? This should be fixed in 1.4

I’m using 1.3 something. Which is the one available in Rhino.Inside®.Revit by default.

Where can I get the 1.4?

In the options you can get the Stable, Release Candidate or WIP (Daily Build)

Thanks Japhy,

I got the 1.4 installed and the problem persists… screenshot:

Can you provide more information on the environment you are working in?

I see that it’s Revit 2020.2, where are the linked files being hosted?

Sure, take a look at the link paths:

Thanks, We’ll take a look and try to can reproduce this.

Can you get the latest Daily Build and give it a try? There is a recently updated fix implemented there. Thanks.

Yes! I will let u know how it goes

With the latest version 1.5.8019.38343, I got a different error:

“1. RhinoInside.Revit.GH: Object reference not set to an instance of an object.”


Ok, Thanks for reporting.

1 Like

No worries. Let me know if you find a solution or fix the bug! We are using this to automate a huge project. Its very handy and having that component working properly will make our lives much better :slight_smile:

1 Like

Hi @Ish,

What about now on 1.5?

We added also an ouput with the link itself to query for its location in the projects and the ability to filter by the link Name.

Does it work wih your setup?

hi Kike,

can you be a bit more specific? The last screenshot I shared is from the 1.5?

If I could specify the location of the linked file, I think that would work. How can I do that? Can you share an example please?