Issue with exporting file to Cura slicer to 3d print

Hi, I have a closed solid polysurface coming from Rhino and having an issue with the top layer. I export stl. Cura says it’s water tight. When i slice, the top layer is missing (when i flip it 180, it’s missing the opposite surface. Also, the infill amount is greyed out. I ran the model through Formware with no change. Attached are my files and setting from Rhino to Cura. Any ideas? Maybe I’m missing something simple. Thank you for any help you can offer. Also, it comes in from rhino way bigger but I’m going from inches to mm so that shouldn’t be an issue. I believe I can just can size it down.
lego test.3dm (716.8 KB)
lego test.stl (1.5 MB)
lego test_fixed from formware.stl (1.5 MB)

Your STL looks fine in Cure here - all faces work. What are your settings in Cura?

I’m wondering if this is just some sort of coincidence between the height of the object and the slice layer thickness that it misses the top surface entirely. If you move the object a tiny bit or make it a tiny bit higher does it help any? I’ll need to fire up my other computer with Cura on it to test.

Thx. Here are my C

ura settings. For some reason infill is greyed out.

thx. I tried dipping it into the build plate just a bit and same result.

I think I figured it out. I’m using a .6mm nozzle. When i switch to a .4mm nozzle, it slices. I’ll have to figure out how to increase the thickness of my model in Rhino.

I don’t have the patience to compare your settings to mine, but the basic ones seem pretty normal. Are you using latest version of Cura’s software?

Have you closed Cura and tried this multiple times?

Maybe save your settings profile and create a new default one & see what happens?

You might want to ask on Cura’s forum, assuming there is one.

Yes, that’s what I was saying about the slicing, it’s only 4.8mm high, with certain slice heights, it is perhaps possible to “miss” a critical slice.

Gentlemen, thank you both! Have it working now. To fix, I did an offset from the solid menu. Had the normals facing inward and .02 did the trick. Thanks again!