Issue exporting text from Rhino to AutoCAD


#1

I use Rhino for my drafting, and for the most part it has been great. However, now that I have to work with others, I am realizing that I have an issue when I export my annotated drawing to autocad. The lines all work fine, but the text is not. It acts as though there is a text box that is too small, and so a single line of text becomes two. This becomes a big problem when I have multiple lines of text (specifying different elements of a structural detail, for example). Not only does it split the single line into two, but it then makes them separate objects. For my own work, I have been exporting the first to a dwg, opening it in illustrator, then exporting an illustrator file and copying all of the text objects and replacing them into the original file. This can sometimes be tedious. The Illustrator export likes to take multiple lines of text and make them one line, but that is much easier to deal with than the dwg export.

Has anyone found a workaround to dealing with text? Is there something I’m missing?

I am using Rhino version 5.3.2 on MacOS 10.13.2


#3

I haven’t yet, but that’s because I don’t have AutoCAD to test it on. I didn’t even realize it was a problem until I got an email back from an engineer complaining about the sloppy text. I have eDrawings (a dwg reader) that I can screen shot to show the issue.

Otherwise, I’ll post a couple test files to help troubleshoot. Just need to clear off some client info first.


#4

Alright, I made the drawings more anonymous. This drawing is still in the early stages, so it’s not fleshed out yet with all the required annotations, but I am hesitant to keep moving forward if this is going to be a bigger issue.

ConstructionDrawing.dwg (62.7 KB)
ConstructionDrawing.3dm (499.7 KB)


#6

It’s a weird font called Kartika, but it’s what the engineer/client uses and wants on this drawing. It has happened with any font I use though. I did a print to PDF so you can see how it is supposed to look on my end.
ConstructionDrawing.pdf (44.7 KB)
Edit: Forgot to click it onto vector instead of raster. It looks better now.


#8

hey @RichardZ
nope, no AutoCad for me.


#10

@RichardZ I tried switching everything to Arial and low and behold, the font exported just the way it was supposed to.

I’m now wondering if Rhino struggles with exporting user-installed fonts. I exported with Helvetica and it looks fine, but I exported with Neutra (which I installed), and it had the same issues again. I even tried exporting with Papyrus and that didn’t have the issue either.

I reached out to my client to have them open it and see what the problem seemed to be, and he said “The text are split into 2 lines, only because the format box has line return that is too short (not sure why).”

Curious conundrum…


#11

looks fine to me in both rhino and auto cad


#12

To better illustrate the the problem that I am having, I’ll attach some screenshots.

This is using eDrawings to preview the dwg file after exporting:


When I re-import the dwg into Rhino, the text still looks like this:

Compare these to the original Rhino file:


#13

yes, apologies i see it now, just tried exporting the 3dm file to dwg and opening in auto cad, the text is definitely shifting


#14

Weird… I just figured out something else that’s strange. The font doesn’t seem to be carrying over into the dwg. I exported with all the text using the font Kartika, but then when I re-imported the same dwg, it was now all Helvetica.

As an experiment, I converted some of the text to Arial and left the other text as Kartika before exporting to dwg and re-importing to Rhino. The Arial is still Arial, but all the Kartika is now Helvetica.

I tried using other fonts I’ve downloaded (non-system fonts) and it’s the same issue every time. The imported dwg has all the text as Helvetica and has shifted everything.


#15

I’d be interested to know if this is a bug or there is a work around for it, I create a lot drawings in rhino, 3d and 2d using layouts, I’m always using architects DWG’s to grab perimeter geometry from to start my 3dm drawings, I’m still waiting for the day when they request my drawings back but in auto cad format :slight_smile:


#16

I’ve always worked around these problems because usually I only have to give people a finished PDF. In this situation I’m just the draftsman, and they want the AutoCAD file itself so that they can make changes… which is proving to be a pain in the butt.

I know there are whole architecture firms that use Rhino for everything, so I assume someone has figured out a solution to this.


#17

To be honest, i don’t care much for auto cad, its used out of necessity to the simplest level :slight_smile:
yes all my output is to PDF mostly, would still be nice knowing that this issue could be fixed


(Fabiano Friedrich) #18

I’ve exported you file on Rhino Windows and the same issue occurs.
ConstructionDrawingFromRhinoWindows.dwg (62.8 KB)


#19

@knotff Thank you for testing that as well so at least we know it’s not a Mac specific problem. Do you have any other user-installed fonts you can test from Windows? I’m wondering if there is some attribute a standard font has that a “downloaded from the web” font doesn’t.


(Marlin Prowell) #20

@RistPhoto Neither Windows Rhino nor Mac Rhino embed font files in the 3DM file or AutoCAD export files. Font files are copyrighted. For a font to have a chance of being reproduced correctly, the same font file must exist on both the source and destination computer.

Kartina is a Microsoft font, but is not intended for Western languages. It is meant for writing in Malayalam script. Does your client require text written in Malayalam script? If writing in Malayalam script is not a requirement, I would suggest switching to a font intended for western languages.

Kartina is available from Linotype for $49. Did you purchase your Mac copy from Linotype? If you downloaded a different copy from somewhere else, I would not expect a free non-western font file to do a very good job of displaying western characters.

I checked my copy of Windows 10 and Kartina is not part of the standard English Windows 10 installation.


#21

Windows7 on my system indicates Kartika is a TrueType font by Microsoft, with standard and bold versions in an OpenType “wrapper”. I believe this will also work on a Mac, but its been years since I’ve had to deal with font exchange between Macs and PCs.

Kartika appears to be a standard Microsoft font, so you could probably grab it off any Windows computer. However, I think it would be ideal if the client gave you the font they have on their system.

Fonts from different sources with the same name may not be the same font. Character shapes, metrics, and the character map may differ.

I suppose you could tell the client they are using the wrong font as Marlin indicates. Or, you could use the same, wrong font they are using?


#22

@marlin I find the font to be kinda weird, and I would never use it, but it’s what the client has used for all of their documents for the last 5+ years, so even thought I would love to switch, it’s what he wants to use. Apparently his choice of font has caused issues over the years, but he feels stuck with it. I would drop it in a heart beat if I could.

@cdordoni I think you’re onto something. I downloaded a free version, but it’s entirely possible that it’s not the same one on his system. Would you be willing to export a file with the Kartika font to see if the scaling issue still exists when it’s exported from a system that has it natively?

I’m still a little confused why standard fonts seem to scale correctly, and non-standard/user-installed fonts don’t seem to scale correctly during the export process. If I’m exporting a dwg and opening it on my own system, then shouldn’t the fonts display correclty?

I’ll reach out tomorrow to see if he can send me the same wrong font he’s using.


(Brian James) #23

Hi all,

Thanks for the report and sample files. I’ve filed this as a bug to make sure the issue gets looked into.
https://mcneel.myjetbrains.com/youtrack/issue/RH-43466

I’ve also found a work around in the meantime, SelAll and Block the entirety of the file, then save as dwg. Importing that back in I don’t see an offset here on Windows or Mac Rhino. I don’t have ACAD to double check there as well though.


(Brian James) #25

Open the ConstructionDrawing.3dm file posted above
Run SelAll
Run Block and choose 0 as the insertion point
SaveAs and choose dwg
Import the dwg