Issue exporting text from Rhino to AutoCAD


(Brian James) #27

I tested the work around in Rhino for Mac as well using the current release version 5.3.2. The steps on Mac are…
Open the 3dm
SelAll
Block (looks like you can block just the text too using SelText first)
Export as dwg
Import the dwg


#28

I just tested converting it to a block and then exporting to a dwg and it didn’t solve the problem for me either, @RichardZ.

@BrianJ I had a look at your error log, but I seem to encounter the problem with any font that I have installed that wasn’t a system font.

When I convert the font in the original rhino file to Arial, it doesn’t happen.
ConstructionDrawing _Arial.3dm (2.9 MB)
ConstructionDrawing _Arial.dwg (62.2 KB)

I also tried doing this with Papyrus and it all worked fine as well.

However, no matter what User Installed Font, I use, the text shifts. Here is an example of the dwg using the free font: Bariol. Notice that the annotation text is all in Arial and it’s fine.
ConstructionDrawing _Bariol.dwg (62.1 KB)


(Brian James) #30

I think you mean the bug report I filed, I also see the text offset issue with any font I choose for the text in your file. I was unable to reproduce the issue making a new file.

This is very strange, I just triple checked on both Windows Rhino 6 and Mac Rhino 5.3.2 that blocking the text first and exporting that block as a dwg imports back into Rhino without the offset. I thought maybe the difference was that I don’t have the Kartika font so I tested your new Arial file too. On that one I still get the offset unless I block the text first. Maybe @lowell will have some ideas, the bug is on his list.


#31

I went into work today, where I have a PC that has AutoCAD on it. I opened the dwg with arial and it showed up exactly how I would hope:


So then I tried opening the original file, and it worked poorly:

I then finally had a chance to try @RichardZ 's suggestion about imported the original 3dm file directly, and the text totally disappeared…

@BrianJ I had a realization as I was driving, and that was that I have been using Cmd+O to open the dwg as its own file. However, I did not actually try “Import” to bring the dwg into an existing drawing. So it’s possible that how Rhino handles the import of a dwg could be different than how it opens it. I will be sure to try that this evening and report back.


#32

@BrianJ It looks like “Importing” the block works and keeps all of the text in order! That makes it even more strange that “Opening” the block doesn’t work the same way.


#33

go to the File menu and press option key


#34

Huh… learn something new every day!


(Brian Gillespie) #35

RH-43466 is fixed in the latest Service Relase Candidate