Iris error


(Noriyuki Yoshida) #1

Me version of Iris expired even with using the latest version Iris 0.6.3.0 for Rhino Windows v6
Is tehre any newer version?%E3%82%AD%E3%83%A3%E3%83%97%E3%83%81%E3%83%A3


(Luis Fraguada) #2

Installers have been updated. Please check food4rhino. Thanks for reporting!


(Noriyuki Yoshida) #3

Thank you for the new version.
I tried using it, but I got an error message saying “Plug-in file writing failed”.
What is wrong?


(Luis Fraguada) #4

Does it fail for any kind of object?


(Noriyuki Yoshida) #5

The same phenomenon occurs even if tried with simple shape.
By the way, the version of Rhino is 6 sr9 latest.


(Luis Fraguada) #6

Are you trying to save in the .html format? If so, I’ve detected an error. I’ll fix it shortly.


(Noriyuki Yoshida) #7

I am trying to save in .html format.
Thank you for correction.


(Luis Fraguada) #8

Installers have been updated. Please check and let me know if the problem persists.
Thanks!


(Noriyuki Yoshida) #9

I fixed it.
thank you very much.


(Wim Dekeyser) #10

@fraguada, I tried Yak to update Iris on my system. After a restart, I get an “Error loading” message - “application initialization failed”. Yak tells me that the installed version is 0.6.1 - 2018-03-14.
Should it work to use the package manager to update Iris?


(Luis Fraguada) #11

Yes it works, but I’ve not added Iris recently to yak (as you can see from the date). In the future, this will be an automated process, but for now it is a manual one that I need to get into the habit of doing.


(Will Pearson) #15

@wim Posting this publicly in case it helps anyone else…

Unfortunately if you’ve previously installed Iris manually (i.e. without the package manager) then you might run into issues. Try first manually uninstalling the previous version:

  • Delete the key from the registry: HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\6.0\Plug-Ins\1cd9c8f5-c901-426c-8e80-d6a2e2b18bba
  • Delete the folder from the plug-ins directory: %AppData%\McNeel\Rhinoceros\6.0\Plug-ins\Iris (1cd9c8f5-c901-426c-8e80-d6a2e2b18bba)

(Wim Dekeyser) #16

Thanks, @will,
That did the trick here.


(Wim Dekeyser) #17

Hmmm….

@will, I spoke too soon.
I was able to export a simple box to html, then closed Rhino and started again. And now I’m getting those Error loading - Iris.WinR6.rhp messages again…


(Will Pearson) #18

Ah, yes. I’m seeing the same thing.

image

I think it’s happening because the 0.6.2 package includes both the Rhino 5 and Rhino 6 RHP files.

@fraguada Rhino currently tries to load any RHP that it finds in a package. Could you try releasing a new version of the package with only the Rhino 6 RHP? The 0.6.2 version can be hidden with yak yank iris 0.6.2.


Latest version is expired
(Luis Fraguada) #19

Ok. I yanked 0.6.2 and pushed 0.6.3 with only the R6 rhp. My apologies for keeping the R5 stuff in there!


(Wim Dekeyser) #20

Thanks Luis!
I used the Update button in Yak to update to 0.6.3.
After a Rhino restart, everything seems to work fine!