Latest version is expired


(Willem Derks) #1

Latest version is expired, are you planning on a time extension else I uninstall to avoid the popup messages.

Thanks
-Willem

EDIT For those oblivious like me: TestPackageManager is a Command run inside Rhino.


(Nathan 'jesterKing' Letwory) #2

If you use TestPackageManager you should be able to get a newer version. I see 0.6.2. released on September 3rd.


(Willem Derks) #3

I still get an issue popping up after running TPM and a Rhino restart
image

I’ll try a system restart and see of that fixes it.

-Willem


(Willem Derks) #4

Hi Nathan,

Using this niche topic to inform you I still see you posting with 2 different accounts.
It’s not of my business if you choose to, but you might not be aware of it.

Groetjes
Willem


(Willem Derks) #5

After deleting the previous iris package it still get a message at startup:
image

Yet in the plugin manager I cannot find the plugin:
image

PMgr also reports no Iris:

Any ideas how to get rid of the startup message? Thanks
-Willem


(Wim Dekeyser) #6

We’ll ask @fraguada \ (o^o)/


(Nathan 'jesterKing' Letwory) #7

I’m very much aware, but thank you for your continued concern (:


(Luis Fraguada) #8

I’m not at the office, but is it still installed in the plugins folder? I also updated the installers on food4rhino btw.


(Will Pearson) #9

@Willem - It does appear like something’s hanging around from a previous install. Might be worth checking the registry to see what Rhino is trying to load at startup. Iris’ info should be stored in HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\6.0\Plug-Ins\1cd9c8f5-c901-426c-8e80-d6a2e2b18bba.

I’ve opened a bug for Steve to include the path to the RHP file in the “failed to load” dialog (see RH-48240).

@fraguada - I just tested the Iris 0.6.2 package via the package manager and it works for me! It loads the Rhino 5 RHP, which gets compatibility loaded, but it works!


(Willem Derks) #10

Hi,

I’ve got it sorted out:

  • Deleted all entries in the registry (V5 V6 and V7)

this was not enough so

  • Deleted all Iris folders in the plugin directories of the 3 version.

That cleared al messages of incompatible Iris

Next ran TestPackageManager to install and all is fine now!

Thanks for the pointers
-Willem


(Willem Derks) #11

Hi,

Today I opened Rhino6 again and got the message back.
this time the details state that the ID is already in use:
image

How would I go about clearing all references before installing the new version?
Or is this the new version conflicting with itself?

-Willem


(Wim Dekeyser) #12

Hoi Willem,
We have another thread going on about this: