Incorrect "Variable fillet edge"


#1

Should I run a variable Blend of red border, with the following parameters: A = 1, B = 3
The result, however, results in an error of construction.

Incorrect blend edge variable.3dm(309.6 KB)
Thanks


#2

Would not it be better to fix this kind of situation? instead of making use of multiple commands, such as: pipes, trim, BlendSrf, for example. to solve this type of exercise.

What do you think?


#3

i was able to get a variable fillet using FilletEdge after running ShrinkTrimmedSrf first.


#4

Thanks Jeff.


#5

You might try a “blend edge” (of 1, for example) the lower edge of this volume?
I could not do, you try.
Thanks


(Pascal Golay) #6

Davide, BlendEdge, FilletEdge do not work if the surfaces along the edges selected are too small to accommodate the fillet. That is unfortunately the way it is.

-Pascal


#7

i think it would help if you can describe exactly what you’re expecting the command to do in this situation… if you can do that then you’ll also start to see where the problems may arise.

for starters, maybe instead of using blendedge @ 1unit, try it at 10 units…
at one unit, it’s hard to see what you’re actually asking of the command but at 10 units, it becomes a little more clear (to me at least)

that should make it more clear that your asking it to fillet a 90º surface which then has an ubrupt change. something has to give somewhere in order to make continuous surfaces throughout and a some point, there will no longer be radius_ed surfaces… but you’re trying to force it to give you a radius surface by using the filletedge and blendedge commands…


#8

Hi Jeff,

sorry my ignorance, where can I activate the FilletEdge trasparent dialog box?
Thanks!


#9

in rhino for OS X :wink:


#10

I thought so, very nice, hope this is rhino for windows future :wink:


#11

i thought about this some more while on the train today and realized there should actually be a solution to it…

got home and started drawing it manually with the file you provided and couldn’t get it to completely join into a closed polysurface… i checked your file’s tolerance and noticed a little weirdness there so i drew it in a fresh file.

this version will actually allow you to run FilletEdge (if the radius is set to ~3.5 or lower) along the bottom edge and the command completes as expected with the proper results. (blendedge will not work on it)

see this file:
works.3dm(312.4 KB)

maybe i formed the variable fillet differently than you did (this isocurves are different between my version and yours) or maybe the tolerance differences have something to do with it? i’m not really sure.


#12

Manually, you can do almost anything with Rhino. The problem occurs when some tasks have to be performed automatically, without wasting too much time building line by line.
This is one of many examples where Rhino is a little weak cases of this type should work; fillet/blend edge constants or variables should not fail, in my opinion.
Do not you think it’s frustrating to have to do many operations by hand, after years and years of software development? Fortunately Rhino 5 works a little better than Rhino 4… at least this is a good sign!


#13

[quote=“davide76, post:12, topic:2357, full:true”]
Manually, you can do almost anything with Rhino.[/quote]

well, that’s what i was saying above… i couldn’t even draw it manually in the file you provided and have everything join up properly… you have your absolute tolerance set to 0.0500000007 units… i’m really not sure if that has anything to do with it but…

when i redrew the shape with default tolerance settings, the fillet worked fine as did your original query without the need for shrinking the surfaces.

i guess my point is this… i don’t think rhino is perfect but i do think it’s vital to make sure you’re giving it proper data to work with in the first place… when someone posts ‘this doesn’t work right’ and leaves it at that, i think you can expect that some people are going to make sure you’re asking rhino to do something that’s even possible to begin with…

but hey, like i said, i know there are some problems in there… for instance, i feel you should be able to draw a cube of 5x5x5 then fillet the edges at 2.5 and have it form a sphere… but that fails.