Image Not Found (Texture Cache)

unhandled

#1

I’ve been using some of the new materials along with the rendered view mode which work perfectly until I try to modify the color of the existing textures. For example, if I go to the custom settings of a preset material, right click on Color and click on Edit Texture, I’m brought to a tab where I can change various settings. Specifically, changing anything in the output adjustment has a 50% chance of returning an error message:

I’ve been able to replicate a similar error message with both the Poured Cement and Concrete Dark materials.


(Nathan 'jesterKing' Letwory) #2

@andy, probably something for you.


(Pascal Golay) #3

Hi Christian - when you edit the texture, is that path shown in the error message the one shown for the image?

Do you have the folder
C:\Users\USERNAME\AppData\Roaming\McNeel\Rhinoceros\6.0\Localization\en-US\Render Content\Textures
?

And is the material already in the file when you open it and edit the texture?

-Pascal


#4

Hi Pascal,

All of the textures I am using are from the new materials included in the WIP. I just tried again using the Maple texture (named “Maple_100_DP” in the folder you noted above) and was able to duplicate the same error. All of the materials are imported using the add material button and navigating to “import from material library”.

I was able to replicate the same error in a new Rhino 6 document as well, so it’s not tied to my file specifically. I noticed a few curious things while troubleshooting:

  1. Although it says “Image not found”, navigating to that exact file path shows that the image is indeed in the texture cache folder

  1. If you look at the above image, the material preview actually updates correctly while the error is shown on the actual object

  2. Changing the variables in each file to match (20x20 size for mapping, 0.2 multiplication and 0.25 saturation in the color adjustment) does not necessarily fail in both files

  3. As I was typing this, the issue seems to have resolved itself in my main file (although it’s still present in the new file I just created). The only thing I remember doing while this happened was changing the texture mapping method, but I changed it back to the original method of WCS box style.


(Pascal Golay) #5

@andy - any idea here?

-Pascal