"Image not found" on shaded textures

We are experimenting with using shade modes for presentation drawings in cases where fully rendered(Brazil) images aren’t needed. We’re running into problems with textures displaying. We get surfaces that are mapped with an error message that the “image can’t be found” and it shows a path to a local cache file that is indeed there. The images referenced in the textures are located on a server in the building. We run into the same problem on all of our (7)workstations.

Most of our drawings consist of linked block models that are also on the server, but I can duplicate the problem with simple polysurfaces. In this case, the only thing on the server is the referanced bitmap. The cache file is local.

The problem is intermittent and seems unpredictable. I can’t duplicate it with any common thing, but it always seems to pop up.


TEXTURE TESTING 12-4A-2015.3dm (1023.8 KB)NO-EDGE RENDER SHADE.ini (11.5 KB)

Read Clement’s reply to my post here:
http://discourse.mcneel.com/t/strange-reflection/27164

Nick

You might not have access to that post, here is his answer…

Hi @nick,

usually this comes up if the default assigned emap cannot be found.
You might check for it in this location when running on a 64bit system:

C:\Program Files\Rhino WIP\rhino_shaded_mode_emap_background.png

or if you´re running in 32bit:

C:\Program Files(x86)\Rhino WIP\rhino_shaded_mode_emap_background.png

If you find this emap in a different place, you can re-assign it to
the Shaded Display Mode by clicking the “Customize” button under:

Rhino Options / View / Shaded / Shading settings / Custom Material

I have “Color & Material Usage” set to “Rendering Material” with “Advanced texture preview” checked. Using 5 SR12 64-bit

In my opinion the missing texture map is likely due to folder access rights or a connection issue with the network drive where you’re storing the image maps. The address for the color channel map in the posted file is L:\DESIGN\BRAZIL\JPEG\METAL\BRUSHED SS 2.jpg

I’d make sure the folder on the L driver has full rights for all users. On a hunch, I might also rename the file to use underscores “_” instead of spaces. It may not be a factor but I’d try it nonetheless.

Hi Brian,
In my case the texture map was just where Rhino put it when it was installed. There could be a rights issue but since the weird reflection occurred only for a couple of sessions it would seem that there must be some other influence.
Nick

I may have misunderstood but the texture map in the material assigned to the objects in the posted file is a custom image. This will be loaded from the location it was originally added from. This is different from an emap such as the one which is by default a part of the shaded display mode.

Brian,
This is where it gets confusing to me. The images that are assigned to the material are JPG files and are on our server. However, the error message “can’t find image” that shows up on the surfaces in our shaded viewports point to a PNG file in a cache folder on our local drives. I’ve checked my drive and the image is indeed there. I’m not understanding why Rhino is doing any of this: Copying my image from the network to local drive, converting the files to PNG, and why it can’t see them in either location. This is an intermittent problem though. It seems to come and go like I’m stepping on the cable somewhere…

I think nick has a different but related issue… Sounds intermittent also.

I get the message I pasted earlier only if adv texture preview is off using your display mode. If adv texture preview is on the model is black but that may be due to not having the texture and there being a custom emap that’s also missing from the file. I’ve only seen the jpg missing texture message never one referencing a png. Can you paste that images address back in reply here?

Can you also attach the image textures used in the material and a screenshot of the file browser (details view) on the server where the image file lives. I want to double check the address as well as it’s format.

@jeff if you have any ideas feel free to jump in.

Sorry to confuse things! I had a similar situation:
http://discourse.mcneel.com/t/strange-reflection/27164

Nick

Thanks for looking into this Brian. Nick, it’s strange, but I got an access error on your link…

The paths:

C:\Users\jthompson\AppData\Local\Temp\McNeel\RDK\Texture Cache

L:\DESIGN\BRAZIL\JPEG\METAL\BRUSHED SS 2.jpg

L:\DESIGN\BRAZIL\ENV\HORIZONTAL GRADIENT 2.jpg

The cache folder has 229 files. Looks like a lot of duplicates, Should this folder be cleared out?



Rhino caches any/all textures, images, what have you, that are used for materials in a cache folder somewhere in the user’s local account temporary folder, and it sounds like the logic for caching and retrieving is messed up somehow in this specific case. @andy probably needs to get involved here since I believe the RDK is the thing doing the caching.

I’ve continued to look for a solution to this. So far, the best answer seems to be to make Brazil materials rather than Rhino materials. If Brazil Caches files like Rhino, it’s sending them somewhere else, and the links just work. The problem I have is that in a rendered shade mode, most of the Brazil material attributes don’t show up. For instance, the color texture will shade, but not the environment texture. I’ll start a new thread with that.

This cache situation is pretty strange though. It would be nice if there was a way to switch the cache from disk to RAM. I’ve watched the cache folder as I work with a model and have seen that Rhino will generate (5) separate .png texture map files for each polysurface. There will be (5) sizes from 32x32 to 2048x2048. Then, if I move the geometry, there will be 5 more. I use nudge a lot to move things around, so each nudge will generate 5 .png files for each nudge. Sometimes, Rhino will lose the link to the original set of files where the geometry was created, but if I nudge the part, boom, the textures turn on and if I nudge it back to the original spot,gone. It feels like there’s a clown inside my computer plugging wires into sockets but he gets the wires wrapped around his foot so they won’t plug in any more.