How to stretch a whole animation?


#1

Hi,

I setup an animation of a watch, one tick per second. Now my client as me for an additional quick loop movement of a part (“riot”), but my ticks are not fine enough. How can I stretch the whole animation so that I can insert a short-time-loop?

Ciao,
Micha


(Luc Adriaenssen) #2

Hi Micha,
Luckily there is the BongoScaleKeyframes command which changes the spacing between keyframes. Have a peek in the Help file (section Timeline Window Overview).
Luc


#3

Thank you for hint. I thought all commands/tools are in the menu, but I see, there is more at the command line. :smile:

I tried it but had no luck. I choosed:
Choose option ( Object View Light Layer Document Content ): Document
Scaling factor <1>: 2
Scaling direction ( Left Right Both ): Right

But nothing happens. I need to scale anything at the time line to get more space between my keyframes but without too loose anything. Did I something wrong?


(Andrew le Bihan) #4

It works here - but my guess is that you’re not picking the right type option. What kinds of keyframes do you have? If you pick “Document”, you’re only going to affect Sun keyframes.


#5

Ah, I thought it mean all key frames of the document. I need it for all key frames, for cameras and objects.


(Andrew le Bihan) #6

Then run the command twice, once with objects and once with views.

Before you say it - I agree. “All types” should be an option. I’ll add it to the list.


(Luc Adriaenssen) #7

Nice going.


#8

The problem is to find all animated objects. Some are at disabled layers or hidden or … . So it’s some times not easy to not to oversee something. Or is there a simple way to scale all object key frames at the same time without selection?


(Andrew le Bihan) #9

I will add something to do this. I’m afraid at the moment there’s no way to modify keyframes on objects that cannot be selected. However, if you make all layers visible, show everything and use SelAll, you should get it to work.

  • Andy

(Luc Adriaenssen) #10

Don’t think so. And unfortunately the Animation Manager doesn’t allow multiple selection - Andy?.

I’m familiar the irritation of fiddling with hidden layers and objects. A hint is to install a keyframe at tick 0 making every layer and every object visible. The actual animation then starts at tick 1 hiding or disabling whatever is necessary. This way you can always turn to the keyframe at tick 0 in order to get a hold on every object.

You can first of all insert 1 tick at tick 0 (use BongoTimelineInsertTicks command). All keyframes (every type) are shifted right without making selections. Then you can install the basecamp keyframe for every object and/or layer. You can take your time to make sure you have them all. Maybe use the Animation Manager as a guide.
Finally the BongoScaleKeyframes trick can take place. Whew!


#11

Andy, could you add a command to scale the whole animation? Could you implement it soon please?

I think it should work with “full” numbers only like 2,3,4 … and not with 1.4. So all ticks could be direct stretched to a new clean tick position.


(Andrew le Bihan) #12

Yes, and yes. I will try to get you a special plug-in for tomorrow.

  • Andy

(Luc Adriaenssen) #13

Don’t agree with ‘integers’ only. Also rational numbers (as is now) can be usefull in the use of the BongoScaleKeyframes command - depending on how the timeline is structured. Fractions can be used to scale down the timeline. The use of decimals is obviously optional.
Of course when a specific patch for Micha is made, that’s another thing.