How to launch Grasshopper in 5.4 Mac

Great news that GH now included, I feel a bit silly asking but how is it launched? grasshopper and explicithistory are “unknown commands.”

Typing “Gras…” autocompletes to “Grasshopper” for me, and “enter” then launches Grasshopper. Not helpful, but at least you have another data point.

1 Like

Are you sure you’re running 5.4?

Yes. Here’s a screenshot showing command lower left and version # upper right.

Quit and restart Mac Rhino. I suspect you are in the initial run of Rhino after the update.

Then does Grasshopper work?

I thought it might be an issue with the auto-update from 5.3 to 5.4, since after installing it the version shows as 5.4 but if I quit and relaunch it shows as 5.3 again.

So I downloaded a fresh copy of 5.4, and installed. But the issue persists.

I quit and relaunched the new copy just to be sure. Same thing.

Could it be some issue with the trial license, “running without saving”?

In Rhino, type this command:
Delete the old ones.
5.4 should be the only one.

I did have a WIP version so I deleted that.

Quit and relaunched, same thing.

I did run the TestFind command again just to make sure, and now the window is empty. Is that normal? I thought the current version should show up.

I restarted computer and reinstalled just to make sure, and now TestFindAll does correctly show current version.

However, grasshopper still doesn’t work.

I’ll need to get some help from the developers on this.

It looks like you’re running an expired evaluation.
That’s why Grasshopper is not loading.
If Rhino detects it can not save; like in an expired eval, then Grasshopper will not load.
Is there some reason you haven’t purchased a license?

My university has purchased a license. But I need to view files when working at home. The trial version allows me to view without saving, which is good enough. I can’t run the license at home since the machine at university might be in use.

Right. An expired eval can be used as a viewer but it will not load plug-ins like Grasshopper.
Mystery solved.

Sigh. Okay, thanks John.

Hello to all
I have the same issue as Eric with a fresh new insall of rihio 5.4.2 evaluation on MAc Os (valid until end of August 2018).
When I look for Grasshopper in Help nothing appears
Thanks for the help

I believe you access Grasshopper from the command line, not the help menu

Did you validate your evaluation license? If not, please run _ValidateLicense, then Quit and re-launch Rhino. Grasshopper should be available until the evaluation period expires.

1 Like

Thanks so much for posting this. I was having the same issue, running a trial version as a student, and validating the evaluation license and restarting fixed the issue. Able to run grasshopped from command no issue now. Thanks again!

1 Like

Hi Guys, I have a customer who purchased an EDU Rhino 5 for Mac lic yesterday. She has downloaded the 5.5 installer, and installed, but said she typed “Grasshopper” from the command line but it does not launch. Any ideas? Does she have to “validate” her lic first as it seems to be the case for the eval/trial version?