How to fix unfillet corners for stl file

Final models.3dm (3.8 MB)
hi everyone
I want to print this models I have in Rhino file with Prusa 3d printer, after I change the format to stl file the filleted corners become straight, while I need filleted corners, do you know what seems to be the problem and how can I fix it?

Hello- I would Mesh the objects in Rhino and verify the mesh before sending that mesh to the printer - it looks like the meshing settings are too coarse


you mean I have to change the radius of fillet or completely delete that?

Hello- no - as far as I can see the objects are fine but somehow the setting at which you are exporting to stl is too coarse - the object needs to be converted to a mesh in order to print - what is happening is that the conversion is too coarse - - as in my top image above, looking at the Mesh command settings

If on export to STL you run a preview, ’

you can look at the results before accepting. But I was suggesting making a mesh object first using the Mesh command and then inspcting those and exporting them to the printer - that way you can carefully inspect the mesh that will be printed.


I am getting some unexpected results as soon as I set a aspect ratio.
Version 8 (8.6.24101.05002, 2024-04-10) on macbook pro intel

I also recommend to use the _mesh command and then export selected.
I recommend to at least set the
“Maximum edge to surface distance” to 1/5 to 1/20 of the layerheight you re printing.
(0.01 will do it for a normal FDM Printer)

minimum edge length can be set close to this value in my option.

I normally use aspect ratio (3…5) to get less spike-like triangles - but looks like something s not working proper here… (see above comment)

just to show the effect - i fillet the edges - to overcome above bug:

Hi Tom -I see that, thanks… I’ll investigate.

DivideAlongCreases > SplitAtTangents=Yes seems to help.

@freesheida1984 you may want to do this as well - meshing works better in general if faces are split up at curvature doiscontinuities.


= workaround.

… but the meshing algorithm should handle it without
= bug (?)

RH-37979 Meshing across tangents

in grasshopper I convert the brep to the brep mesh, and I got this preview for my print. It seems that the problem is fixed(I doubt it a little) but please check this file if it is possible please, thanks in advance.
Final models.3dm (692.1 KB)