Exporting stl mesh files from rhino


#1

Hi everybody.

I am trying to export an stl file from rhino for 3d printing. The problem is that although the surfaces are smooth. when rhino creates the mesh the surfaces become rough (looks like a lot of small square faces) although in rhino the mesh looks smooth. when i print the file all these small face are visible on the model.

I am attaching two images of the problem (the blue is Geomagic studio).


Thank for the help

Roi Ramot


(Menno Deij - van Rijswijk) #2

This is a rendering “trick”, Rhino uses the mesh normals to make the mesh look smooth.

You can make the export mesh by hand using the Mesh command, and play with the parameters after pressing “Detailed Controls” to get more (smaller) faces.

Then export the created mesh to STL for 3d printing.


#3

If I export an STL I use the following settings.

Just give it a try :slight_smile:

I think your file size will increase too.


Converting to STL for printing created new and bad geometry! Help!
#4

View the model using the FlatShade setting in the View menu in Rhino. This will show how the mesh actually looks as modelled, and the best that your 3D print will be. You can see the slight faceting on your Geomagic screenshot.

If this is still too faceted for you, then tweaking the mesh export settings won’t help. It would probably be best to remodel your design in Rhino as a NURBS surface model, then export your surface model as a higher resolution mesh.

Also try giving the Maximum Edge Length setting a value to help get some control of over the exported STL mesh.

David


#5

OK so I played a little with the mesh settings and got a much better result.
Basically I used the following parameters:

density - 1.0 (when i used 0.0 the mesh became much more faced)
maximum angle - 0.0
maximum aspect ratio - 0.0
minimum edge length - 0.0001
maximum edge length - 0.3 (this did the trick)
maximum distance - 0.0
minimum initial gris quad - 0
with refine mesh checked.

Thanks again for all the help :smile: