STL export not working properly

Hi,

Rhino 5.5.5 for Mac reports the attached object as a valid polysurface but when I export it as a mesh (STL) the result is incorrect. In the screen grab, pink is the 3DM, blue is the exported STL.

Can somebody please explain why?

Wheel.3dm (7.8 MB)

Then you mesh settings are incorrect for your needs.

Best practice suggests:

  1. Use the Mesh command to create a mesh from your closed polysurface. Adjust the mesh creation settings to get the mesh density and fit that your printer requires.
  2. Hide the polysurface
  3. Inspect the mesh using the Check command to make sure it is a good, closed mesh. Repair as needed.
  4. Export the mesh to STL.

For your object, these settings make a better fitting mesh:
image

That said, I do not like how complicated and over parameterized the wide areas are on your wheel. This excessive control is likely to cause down-process problems.

Any luck?

Hi John,

Your mesh settings indeed cure the problem but in so doing take the file size from 6 to 140 MB!

What I don’t understand is that I have exported the same design as a mesh with only a couple of structural alterations to parts not associated with those that produce the problem without issue. Normally, I don’t have to tamper with the default mesh settings at all.

How would you suggest I de-complicate the wide areas of the wheel? I assume you are referring to the 6 concave surfaces. I created these using the Network Srf command using only 4 open lines and do not see how I can make these surfaces simpler without losing the edge matching tolerance I wish for if moving to machined parts.

Thanks,

John

Hello - please try this: Start DivideAlongCreases, set SplitAtTangents = Yes, then select the object and Enter. Then mesh at your previous settings and see if that looks any better.

-Pascal

Hi Pascal,

I read this suggestion of yours at an earlier time to another user but it didn’t make any difference in my case.

Regards,

John

Hi John - it should help - it does here, in V6 at any rate

Same mesh setting, split on the left, original on the right.

-Pascal

Hi Pascal,

That makes the issue further confusing, as I obtained no change in V5 – but, perhaps I need to repeat to make sure.

I have tried something though…rather than using Network Surface to obtain the concave surface indents, I have simply swept a 0.5 mm radius arc around a single rail then capped it with a flat base. When I do this, I have no problem exporting as a mesh using the default settings (see attached). Does this provide any clues?

John

Wheel v2.3dm (4.58 MB)