How to change the color of a crosshair?

At John Brock’s suggestion I am opening a fresh thread for this topic.

I cannot easily see the crosshairs against a grey field. When I attempt to change the color of the crosshair, the change will not happen.

Using Rhino 5.

Opened Properties, went to Appearance, then Colors. Scrolled down to the “crosshair” tier and changed it from null to Green. Okayed the change – but it won’t stick for some reason. On the screen the crosshair is barely visible, not Green. .

When I return to Appearance/color/Crosshair, it shows a null color, not green.

Tried it again with red. Same problem. The change is ignored.

Have I left something undone?

Related issue. In the Perspective and Top views the crosshair is especially hard to see because the actual crosshairs and the central dot are missing for some reason.

Thank you for your insights. Michael.

Hi Michael -

What is a “null” color?
What happens if you change any of the other colors in that interface? Does that stick?

Hello Wim, thank you for your help.

I used the term “null” color to signify a color not chosen by the user. In the case of the crosshair, it appears to be white or a very light grey.

I used the Properties/Appearance/Color selection menu to change the color of the Select Object from yellow to Cyan. Worked fine, no problems.

I attach the 3dm. Note that this is Rhino 5.

There may be something wrong with the CPlane, notably in the Perspective panel.

Thank you for your insights.

Michael cradle expts 8-12-20.3dm (1.2 MB)

Color changed here:

Try this file (V5):
cradle color change.3dm (1.2 MB)
Any luck?

Many thanks for exploring this. Here is the menu panel I found in the file I downloaded as Cradle Color Change.

On the Appearance/Color/Crosshair menu (see screen grab) the color appears green, rather than pink. On the Rhino display, the crosshairs, which consist only of four compass quadrant pads, are white, i.e., colorless. No crosshairs, no centerpoint


Maybe I should reinstall Rhino. Recently I receivedd some Win 10 updates, and these may have caused problems.

Do you have “Crosshairs” checked in Options>Appearance? What you are describing is the normal cursor when a command is in progress - without crosshairs being enabled. That cursor color cannot be changed AFAIK.


Hi Michael -

Also note that the crosshair color is a Rhino option, not a document setting. This setting doesn’t travel with a 3dm file.

Thank you.

The “Crosshairs” box was not checked. They immediately lit up in the correct color when I checked ithe box, so this was the solution.

Hi Wim
while following this thread, It took some looking to find how to switch Crosshair on [on the Mac side]
Is there a way [macro perhaps] to toggle it [True / False ] so it can be set to a button?
The only checkbox I found is in Pref. > Advance

thanks a lot

I don’t see a way to do that with a command macro.

I’d suggest reposting this in the Rhino for Mac category since it does not apply here.

Sure. Can we have a Crosshair toggle [via a button] please
[it’s just that the Windows category gets much more attention then the Mac. A macro/button for crosshair toggle is perhaps relevant for both…

thanks a lot

In this specific case, I think they will be very different. One would not likely work on the other platform.

This works on Windows to toggle the crosshairs:

! _-Options _Appearance _Visibility _Crosshairs !

on Mac it would then maybe be:

! _-Preferences _Appearance _Visibility _Crosshairs !

But I haven’t tried it… maybe someone could.

I made a small python script for toggling the crosshairs…

1 Like