How is the Demo version supposed to work? And other gotchas of a returning customer


I downloaded the Rhino v7 demo version for Windows shortly after it came out.
This demo is now expired.
On the download page it says:

"Rhino 7 for Windows - Evaluation - Try this full version for 90 days. After 90 days saving and plug-ins stop working, unless you buy a license."

So I did assume that I can still open the software even after it has expired.

I tried this today with a fresh install of the latest Demo version but all I get is an endless loop.
First a screen telling me this:

“The licenses for Rhinoceros 7 in your Rhino Account have expired”
“You may need to ADD A LICENSE”
“Then try again”

I do not have a Rhino 7 License to add, that is why I want to test the demo…

If I close that screen, I get to another one:

“Rhinoceros 7 needs a license”
With several options, none of them being to run a demo.

If I close that screen, I’m back at the first one…

How is that supposed to work?



Windows 8.1 x64

You should have gotten a license key in the mail when you downloaded Rhino. How did you install the key (if you did)? Locally on the machine or did you create a Rhino account and put the key in the Cloud Zoo?

1 Like

When I try to enter that key, I get the information that it is expired and can’t be validated.

You’ll probably have to remove the expired V7 eval key from your Account login, and add it as a stand alone license.
Then it will run without the ability to Save/Export or load plug-ins.
It will work great for running tutorials or as a viewer.

To Remove a Personal Cloud Zoo license

  1. Go to the Rhino Web site Licenses page (log in to your account if necessary)
  2. Click your name in the Personal licenses section
  3. Click the license name
  4. Click Remove
  5. Add the license Stand Alone:
  6. Single computer licensing [McNeel Wiki]


1 Like

Wow, that’s the most convoluted mess I’ve ever seen.
How is anybody supposed to come up with that solution?
Why doesn’t any of those screens contain a hint for demo users?
That second screen holds many options, why not make one for the Demo there?
Not even sure why a save disabled demo would need a license to run?

Well, whatever, at least Rhino doesn’t run in circles now and opens.

Thanks, I guess.


The instructions for adding it initially do have that information:

I seem to be out of luck.

The demo download pages says:
" This is the evaluation version. Saving and plug-ins stop working 90 days after you download, unless you purchase.
(After 90 days, it will still work great to learn Rhino and to view Rhino and many other file formats.)

I just tried to import an obj file to test the subdivision surfaces for an upcoming job to see if it will do what I need, but I get only:

Error importing file “ObjectPath/AndName.obj”.

I imported exactly the same file into the demo before (before it was expired) so I know Rhino can load it.

Is OBJ somehow not in the list of what the expired Demo can load?


That appears to be the case.
Expired V7 eval does not open OBJ files.
It should work.

I’ve logged a bug.

1 Like

Hahahaha, I seem to stumble over every possible issue, first Cycles not working with multiple GPUs, now these…
Somehow I don’t seem to be compatible with Rhino… :wink:

I’ll have to see if I just stay with my old Rhino 5 or take the plunge regardless of my complicated relationship with this software and it’s - to me - alien mindset.

Working in Houdini for years has me seriously spoiled.



If V5 is still getting the job done for you, then there’s no benefit to upgrading.

Be well

1 Like

RH-63064 is fixed in the latest Rhino 7 Service Release Candidate

Don’t see that fixed here, still getting a black rendering with a GTX 1080 TI and a RTX 2080 TI in Cuda Mode. Windows 8.1 x64, 64 GB RAM.

I bought the Rhino 7 update in the meantime, since I have a job coming up that can use some of the new features. Anything special I need to do? Drivers are current, setup works with all other renderers…?



Hey John,

I don’t follow you? I thought Brian was saying that it’s fixed in the latest Service Release Candidate?
I have Rhino 7 SR5 2021-3-9 (Rhino 7, 7.5.21068.13001) installed - isn’t that the latest?



And is it true that when I download several package with the package manager in a row, I have to start Rhino once for every one of them?


Sorry. I posted my comment int he wrong thread…

My bad.
As you were…

1 Like

The item that Brian mentioned as fixed has to do with opening obj files in an expired evaluation version of Rhino.

1 Like

Ah - so it was the other bug.
I was trying the link to the issue but it was gone already, so I somehow assumed it’s about the dual GPU rendering not working.

I think after closing and re-opening Rhino about 15 times to install plugins one by one (and before that going nuts for one or two hours finding out why the installed plugins don’t show up), my limit of Zen-patience for the day is spent.
This will be an “interesting” ride…

I don’t believe you need to restart Rhino after every item is installed with the package manager.

I’d be interested to hear the alternative.
I got my license today from my reseller and thought I’d install everything I either had with Rhino 5 or that sounded useful. Since the descriptions of the items are in many cases completely useless, I also installed some things to hopefully find out what they are.
I installed something like 15 items via the package manager in one go.
I re-started Rhino, expecting that all the installed things would be available afterwards, like it works in pretty much every software I’ve ever used.
They were not.
I was especially interested in the substance importer.
I looked through all menus and preferences and finally found the folder where the plugins are.
Everything looked fine, they were all there.
I restarted again, to no avail.
Then I manually installed the rhp in that substance folder in Rhino.
That worked.
I went to the forum to see what I’m missing, I read this thread since there was a notification, thought I try the dual GPU rendering - didn’t work.
So I checked if there are new Nvidia drivers - there were, downloaded those and installed.
No change.
Had Rhino closed down for that and when starting it, I noticed a window that said it’s installing something that sounded like one of those plugins I installed with the package manager before.
No, that can’t be…
Closed and re-opend Rhino and the next item was installed.
Looking completely flabbergasted at my screen for a minute or two.
Are you serious?
Spoke a couple of mantras and gave into the unavoidable.
I’m a leave in the wind…
And then I sat there for a while just closing and opening Rhino.
Each time a different plugin was installed.

This is my first day with my new license of Rhino 7.
Interesting times ahead.

I don’t know who comes up with that stuff but Rhino is a bit like studying Zen.
You get continually confronted with very confusing things that seem to make no sense at all.
And over time, you may or may not get enlightened.
Or get mad.




@will and @Trav, you might want to read the above comment. It looks like there are some tune-ups to the PackageManager UI that could help.

1 Like