How do I install Hoopsnake on Rhino 7?

I am trying to find a way to integrate looping functionality into a series list of subdivided surfaces that have a surface morph operation happen on each of them, terminating the loop upon the surface morph of the final surface, by measuring a multiplier for the subdivisions to give that number on the maximum number of surfaces created. Strangely I have been having difficulting installing looping add on functions, and considering whether this should just be done in Python, or whether I can do this within GH. Any insights? I am making shoes. SHOE_STYLE#3|690x388

Hello - Hoopsnake support email is
contact@yconst.com

I’d start there.

-Pascal

1 Like

Any luck? :grinning:

Use Anemone instead.

1 Like

@Joseph_Oster I have tried using Anemone and install the .GHA file into my Rhino Grasshopper plugins files… but when I open the file it says its not compatible and have been trying to find a solution. Could you walk me through how you would install it for Rhino 7?

1 Like

I don’t recall re-installing Anemone when I upgraded from R6 to R7. It still works fine, WAY BETTER than Hoopsnake ever did (which for me was never). I am using Anemone 0.4 (2015-12-14) from this page: Anemone | Food4Rhino

In Grasshopper, use ‘File | Special Folders | Components Folder’ to locate this on your machine. On Windows, you might have to right-click the file, select ‘Properties’ and check the ‘Unblock’ box.

1 Like

Ok… So I redownloaded 0.4 version, installed it into the library and checked the unblock and it is still not allowing me to use the plugin… after I selected unblock the option to check that box has disappeared.


1 Like

I don’t know what more to say, Anemone has always worked great for me in R5, R6 and R7.

Welp… that is a bummer… hey @MateuszZwierzycki do you have any insights into what could be going on here?

1 Like

Thank you for trying to help assist in this matter

I tried installing it in the libraries with Rhino7 to no avail as well.

Sounds more like an issue for McNeel than Anemone’s creator, Mateusz Zwierzycki ? I’m sure there are others that use Anemone with R7 like I do.

1 Like

I guess you’re trying to install it as a Rhino plug-in, please make sure you’re installing it in Grasshopper.

By “libraries” i meant the grasshopper libraries. :confused:

Hey @mcneelsoftware do you have any insight into why this may be happening?

Taking a wild guess here… At the Rhino command prompt, type ‘PackageManager’ and then click the ‘Installed’ tab. See anything weird that might indicate Anemone installed in the wrong place?

Strangely enough, I don’t see that I have anything installed, but I know for a fact that I have additional plugins installed and operating within my grasshopper program. I also am not seeing that Anemone is something I can search for online. I do not know if the package manager has the Anemone plug-in referenced within its library, and is indicative of a technical error or not.


As far as I know, PackageManager handles Rhino plugins only, not Grasshopper. They are separate so I’m not surprised you don’t see any GH plugins with PackageManager. Had to look though because it doesn’t make any sense that Anemone doesn’t work for some.

The package manager handles both. Hops is a GHA and is distributed via the package manager. It is up to add in authors to publish their work to the package manager

So what is preventing these guys from installing Anemone in R7?