Icons in Grasshopper for Rhino v06 have disappeared

unhandled

(Tijl Uijtenhaak) #1

All,

Today i installed an evaluation version of Rhino v6.
When i try and access GH it seems the icons don’t load.
please see attached screen shots:

did anyone else encounter this? And if so how should i resolve this. .
i’ve tried rebooting and reinstalling…

Thanks,
Tijl


(David Rutten) #2

Looks like your Hoopsnake plugin is corrupt and messing with the loading routines. Can you find it on your machine and send me a copy of it? then either rename the extension to .notgha or delete it entirely and download anew.


(Tijl Uijtenhaak) #3

Hi David,

Thanks for the swift response. Attached is the zip for the hoopsnake.
If I disable/remove the hoopsnake it still doesn’t work… .
There are some mysterious files not referenced in.

Thanks,
Tijl

hoopsnake-064_0.7z (62.0 KB)


(David Rutten) #4

What’s the new error message?


(Tijl Uijtenhaak) #5

hm… reboot after deleting the hoopsnake at all locations has solved it!
now up and running!

Thanks!


(David Rutten) #6

Based on looking at Hoopsnake with ILSpy I think it has been obfuscated. I really wished people’d stop doing that, no end of trouble whenever a .NET update rolls along and specifically closes some loopholes obfuscators were relying on. Boom, instant crashes.


(Tijl Uijtenhaak) #7

Thanks! at least if other people run into this error, it might be easier to resolve.
If i happen to need hoopsnake again, i’ll have to contact the developper unless something similar has now been integrated in GH? Hopefully he and other developers will follow your advise about the obfuscation.

Thanks for the super quick fix!


(David Rutten) #8

As far as I’m aware only HoopSnake and Anemone provide network looping logic. I’d like to experiment with it myself, but it’ll have to wait till GH2.

Glad it was fixed relatively easily.


(qythium) #9

Just FYI… Hoopsnake also causes instant crashes upon startup for GH Mac, it’s quite a shame since the basic functionality doesn’t seem to be platform-specific :confused: