Grasshopper breakpoint

Hi guys,
I have a problem with a gh. I’ve just installed rhino 6 and this error ocured:


after continuing gh starts but the tabs are plain

What to do? How to live? plz help :slight_smile:

BadImageFormatException typically means the dlls that make up the components are not loadable. The problem also seems to be the hoopsnake plugin, which I’m assuming you have installed for GH on Rhino5.

What you can do is find the Hoopsnake.gha file and put a blank file next to it called Hoopsnake.no6. This will prevent it from being loaded by GH on Rhino6.

Or perhaps updating to a newer hoopsnake may also solve the issue?

Unfortunately it didn’t work out.

step by step:

I’m starting the new file and choose the meter template

type in command console “grasshopper”

the warning pop’s up

the gh shows me my recent files which were made in Rhino5 but the tabs in ribbon are blank

I also can’t open old files/projects

I can’t update the plugin because the last update was in 2014

I made an empty file with the extension you mention

It didn’t work

the same warning occurs.

I’m looking forward for your help. plz

But can you clarify that you in fact have removed hoopsnake?

That means Grasshopper is still trying to load Hoopsnake. Can you search your entire computer for _Hoopsnake.gha and rename all the files to _Hoopsnake.notgha? That should definitely disable them all.

I’ve tryed what you mantion didn’t work
I’ve deleted them all. didn’t work
This still occures


and the gh is blank, no params no maths… :frowning:

Ok.
Problem solved.
I had to dig in to appdata/roaming/grasshooper/libraries to find this.
After deleting it worked
Thanks for help. :smiley:

Continuing the discussion from Grasshopper breakpoint:

Hi
I have same as your error
I downloaded hoopsnake…
But I can’t solve it yet
I need your help

Hi. The rest of The hoopsnake was hidden quite deeply. C/users/computer/AppData/…
This folder is probably hiden. And i dont remember but search in roaming or local folder.

I Found it, do I need to delet it?exactly after I found it, what I have to do?

Yes. And it should start working. :slight_smile:

The Grasshopper plugins folder is not hidden.

Just click the File menu File \ Special Folders \ Components Folder and you end up in the right place:

// Rolf

I’m also getting the long list of errors at the break point.
I haven’t had the hoopsnake installed. However I tried installing it and then renaming, still nothing changed. Some of other plugins have missing components from the toolbar.