How can i make my icons bigger?

windows
display
unhandled

#1

Hello the icons on my Rhino are tiny, I have tried many display settings on my Windows 10 but cannot find the right one. I hope you can help?


I'm feeling old all the sudden
Rhinoceros 5
(Pascal Golay) #2

Hi Arthur - setting the Windows display settings larger should help - right click on the desktop > Display settings. Also, in Rhino Options > Toolbars > Size and Styles page you have some, albeit limited control over sizing.

-Pascal


(John Brock) #3

Hi
There are a several things you can do to make this work better.

In the Windows Control Panel, use the Display applet to increase the size of icons and text to 150%-200%.

In Rhino Options - Toolbars - Sizes and Styles, set the icon size to large. That should be much better.

In Win 8.1 and Win 10, you might need to turn off “Display scaling” too. Browse to the Rhino executable, right-click, select Properties/Compatibility/Disable display scaling on high DPI settings:
https://www.microsoft.com/surface/en-us/support/apps-and-windows-store/app-display-issues?os=windows-8.1-update-1


#4

Thank you @John_Brock and @pascal I’ve tried setting the display setting zoom to larger and smaller, I’ve disabled the DPI settings in properties and have scaled the buttons on the Rhino Options but it is still similar unfortunately:

please note also that the display problem is affecting the snapping as shown on printscreen below so it makes it hard to use/teach rhino:


(Steve Baer) #5

I believe there are ways to get Windows 10 to put Rhino into a compatibility mode for running under lower reolution. If it is important for teaching a class, you can aleays change your display resolution to a lower setting and adjust the text scaling to 100%.

We are putting a lot of effort into improving these high resolution issues in Rhino 6. Unfortunately it is a major effort and not something we can just fix in a service release without incurring the risk of messing other parts of Rhino up.


#6

Thank you very much @stevebaer and @John_Brock, I look forward to it! All my colleagues are having the same issue unfortunately.


(John Brock) #7

With a System Registry key addition and copying a manifest file to the folder where 64-bit Rhino V5 lives, you can fix the small icon problem on high resolution monitors.

The details are in this new FAQ support document:
http://wiki.mcneel.com/rhino/5/video/highres/toolbars_and_text_too_small_in_64-bit_rhino_5_on_high_resolution_screen

This also fixes the same issue for Grasshopper in 64-bit V5


(Gustavo Fontana) #8

thank you so much guys! V5 and Grasshopper are now looking much better. =I’m realizing it’s time to redraw all my custom icons to high rez. not big deal, they are only like 100+

also, is there any way to change the size of Grasshopper interface a bit, the new default after this registry change looks a bit too large. Thanks!

G


#9

Hi John,
Many thanks, we had two MSI laptops in the office with the same display issue with Rhino. The fix worked on the laptop that had windows 8 but not on the one that has windows 10. Is that normal or do i need to do something else on windows 10?
Arthur


(John Brock) #10

Windows 10 is exactly the same.
Make sure the manifest file is in the correct folder:
C:\Program Files\Rhinoceros 5 (64-bit)\System,

and the System Registry key addition is correct:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CUrrentVersion\SideBySide]
“PreferExternalManifest”=dword:00000001


#11

Hello,

The icon size issue is now fixed through the suggestion above, however the cursor still remains tiny. (The arrow is fine, but the small square when selecting or drawing, is too small). I would appreciate your feedback.

Thank you


(Pascal Golay) #12

Hi Andrew - is this a graphic element or the size of the active pick area when you click down?

-Pascal


#14

Hello John,
Thanks for your solution, and I’ ve succeed in making my icons bigger.
The only problem is that my LAYERS MENU disapears as the picture shows.
What can I do with this problem?


(Yhung219) #15

Hi John,

Is your link still relevant? I’m also having the problem of tiny icons on my high-res screen. I ran Service Release 14, and the icons are still tiny.

Thanks,
Yvonne


(John Brock) #16

Yes, if you’re running Windows 10 Creator’s Edition (1703) or the Fall Creator’s Edition (1709), and are running on a screen with higher resolution that was available back in 2012 when Rhino V5 was released, then Rhino will be too tiny to use.
SR14 adds the tools needed to use “recommended” Windows display resolution and display scaling (Control Panel), and then Rhino will look OK.

In addition to SR14, there are specific settings for each version of Windows that are detailed out on that support page.

If you aren’t running in the 4k+ resolution range, then you may not need the SR14 tweaks, so we added the SetDpiAwareness command giving you the ability to disable the new scaling feature needed for this problem.


#17

Hi
I’ve just downloaded V6 and can’t change the icon size. I’v gone to settings and tried all three sizes and none of them seems to make any difference. I thought this issue ws fixed in V6. Any suggestions?

Thanks
Paul