Toolbars and text too small in 64-bit Rhino on high resolution screen

rhino
tinyicons
highresolution
unhandled

(John Brock) #1

I recently picked up a Microsoft Surface Pro 4 running Windows 10.
On the tiny 12", high resolution screen, 64-bit Rhino 5 for Windows was unusable even with all of the suggested display scaling and icon size increasing recommendations.

With the suggestion of another Discourse post, I made an external manifest file for 64-bit Rhino and set a registry key to tell Windows to use an external manifest file if it exists.
This completely solved the tin icons and squished up display problems, including Grasshopper.
This system is not a good choice for production work, but it’s great for a portable, light weight, “usable” platform.

Here are the details for fixing the display problems:

http://wiki.mcneel.com/rhino/5/video/highres/toolbars_and_text_too_small_in_64-bit_rhino_5_on_high_resolution_screen

If you want a preview of what it will look like, run 32-bit Rhino 5 on a high resolution
screen.


#2

John_Brock , I know you’ve answered me before on the problem I had with the 64bit reg hack to make toolbars and text larger ( which was that immediately after applying the hack my Taskbar Clock-Calendar would not pop-up on a mouse click over the Time-Day in windows 7 64bit) saying that there is no connection possible…Yet I tried twice and it happened both times and a simple “system restore” resolved that problem. Not only would the Clock-Calendar not pop-up but I saw no difference in the size of my text or toolbars, not to mention tabs which is really too small for me. I was wondering if you might give me the path and explanation for the reg change so that I might try manually applying it through “Regedit” I’m not an expert, but I have used regedit numerous times, and I will make a backup before making any changes. My amateur thinking is that the reg change is being merged in the wrong line in registry. I would really like to solve this problem.


(John Brock) #3

The System registry key that tells Windows to prefer external manifests is as follows:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVerson\SideBySide
REG_DWORD: PreferExternalManifest
Value Data: 1


#4

thanks


#5

Hi John
I am using a surface pro 4 running windows 10 and installed the external manifest file to fix the small icon display issue, but when I reboot rhino after placing the manifest file in the folder I am unable to access my layer menu the menu appears non responsive and even after exiting it and adding it back it still does not work. This problem occurs every time I open rhino on my surface, but when i have the surface connected to an external monitor the problem disappears. I have included a screenshot of my issue, could you please help resolve this issue
thanks


(John Brock) #6

It sounds like you installed the Windows 10 “Creators” update:


#7

that would be it, thank you very much for your response


#8

@John_Brock
I’m running rhino 5, 64 bit, on win 10 with Creators Update, on a 4K screen.
Just did a fresh reinstall of the OS and all programs. Applied the rhino for hi-res screen fix from the Wiki and everything was working fine, till a few days ago Rhino kind of froze for a second with its window not maximized, and when it came back to life the text of the Command line area and the very bottom of the window (x,y,x, units, etc, is very tiny. Tiny like, it’s ignoring the 150% scaling I set in Windows.
I tried re-applying the hi-res fix but nothing.
Everything else is fine, toolbar icons are big according to the hi-res display fix, it’s just the text. Could send you a screenshot but no idea how to.
Note: Rhino froze while I was rendering with Vray 3, I have the suspect vray made it freeze, but I guess this text issue is Rhino’s and not vray’s.
Any ideas?
SR14 installed, latest vray version installed, Windows up to date.
Thank you,
Guido


(John Brock) #9

I would first see if there is an updated display driver for your setup.

If that doesn’t solve it, try the TestToggleFileDialog command.
If that sorts if for you, add it to Options > General > Commands to run when Rhino starts.

Last resort is the SetDpiAwareness command and change it.


#10

Tried both commands but text is still tiny. I even tried launching the installer and doing a Repair, the issue persists.
Rhino


(John Brock) #11

What Windows version are you running?
What screen resolution are you running?
What is your Windows Display: Scale and layout magnification?
What is your Text Size in Rhino Options > Appearance?


#12

John,
Mystery solved.
For some reason the Text size in the Rhino options was set to 6. I
changed it to 10 and text size is back to normal.
Considering I never changed that setting, there must be a bug somewhere
that did. My suspects are on Vray…

BTW, running Win 10 64-bit with Creatr’s Update, 4k screen res, Windows
scaling set to 150%

Thank you!
Guido

John_Brock wrote:


(Yafimski) #13

hi all,

i’m having a similar issue but none of the solutions I found online worked.

I was doing some Ladybug Grasshopper scripts and my computer crashed, afterwhich my screen resolution was tiny (all the desktop icons were tiny) and I was able to return then to normal by changing the Display % of my windows 10, but then rhino icons were tiny.
I tried playing with the compatibility settings of Rhino Application in several ways but I can either keep them tiny or slightly too big… they don’t reset to a correct size any way I do it.

My windows itself is in the right display, but I don’t have the ‘advanced options’ of the display (due to this feature’s removal by microsoft) and my taskbar is slightly ‘cut’ from the bottom. I can’t change the actual resolution, only the % scaling, which is now on 300%.

Is there anything you can help me with? (or more information that you need)

Thank you


(John Brock) #14

I think you’re describing something that is linked to that support page you may have overlooked or skipped.
Start Rhino and do something that opens the File dialog like Save or Open.
Does Rhino’s icons get squished after that?

If so, here’s the detail you missed and how to fix it:
https://wiki.mcneel.com/rhino/5/video/highres/toolbars_and_text_sudenly_shrink


(Yafimski) #15

@John_Brock

Actually I’ve looked at that support page and it didn’t help.
My issue isn’t that icons become smaller during something, but that they are initially already either too small or too big as per my original description.


(John Brock) #16

Control Panel:
What screen resolution are you running?
What scale factor is your text set to?

Rhino:
What size are your V5 icons (Rhino Options)?
Are you running V5 SR14?


(Yafimski) #17

I have uninstalled the Intel display driver I had on my Windows, it seemed to have fixed part of the problem on my Desktop, and the rhino icons are ok, but the ‘layers’ tab in rhino isn’t functional, just a white window.

[Rhino Layer Issues - Layers disappeared from layer tab]

I saw ppl have run into this and it related to the latest windows 10 update I think, but i’m not sure if it has been resolved since. Any ideas?


(John Brock) #18

The blank Layers panel at higher screen resolutions in Windows 10 1703 and 1709 were specifically what the SR14 update fixed.

I suspect you are NOT running SR14.
Look in About Rhinoceros in the Help pull-down menu.


(Yafimski) #19

Thanks, I will try to update SR14. :slight_smile:


#20

I just enabled VRay on my system here at work and had the same issue (i.e. tiny text and thinking it was related to setdpiawareness). This was not the case, and the Rhino text was indeed set to 6 all of the sudden (down from the default 9 if I recall):

In case you aren’t aware of this @matt_newberg.

Cheers,

Anders


Rhino 5 Standard Render: Two-Sided Materials Possible?