Holomark2 fails loading

Hi, Holomark2 R6 works for Rhino 6. But Holomark2 (not R6) is for Rhino 5.
The one in the link Nathan provided should work.

I just installed it here, and in none of the versions (6, 7 and 8) the plug-in wants to initialize correctly.

OK, I’ll check it out! (can’t do it now though, sorry)
Maybe something has changed in newer SR’s that I have to adapt too.

No need, I just ran some tests to see if I could get more info: dragging the RHP from the location the plug-in is installed to onto Rhino 6 (or 7, or 8 from the correct respective locations) works fine.

This sounds more like an error with the installer engine.

I’ve logged RH-62709 Plug-in install ok, loading fails to track further investigation in this issue.

OK, what should I do then to use Holomark on Rhino 6 and 7?

You can drag the RHP file manually on Rhino 6 and Rhino 7

For Rhino 6:

  1. open File explorer
  2. paste %APPDATA%\McNeel\Rhinoceros\6.0\Plug-ins\Holomark2_R6 (6733c793-b8cd-f362-2097-bda699f6f4ac)\ in the location bar
  3. find in one of the sub-folders the file that ends in .rhp
  4. drag it on a running Rhino 6.

For Rhino 7 almost the same, except you look in %APPDATA%\McNeel\Rhinoceros\7.0\Plug-ins\Holomark2_R6 (6733c793-b8cd-f362-2097-bda699f6f4ac)\

Nothing. I’ve done what you said. When I drag the .rhp in Rhino, it tells me “…already loaded” and then nothing happens. If I type Holomark it tells me only built to run on Rhino 5.

Regarding the Rhino 7, it doesn’t install it at all.

Any suggestion?

The command name is HoloMark2_R6. You ran that, or just HoloMark?

Sounds to me you may have an old version still installed somewhere if that is the case.

FYI @gianandreafiorillo I just ran HoloMark2 in Rhino 7 on my RTX A6000

I ran Holomark. My mistake. Anyway, I ve never installed an old version… Do I need to get rid of it before running Holomark_r2? How?

Tomorrow morning at the office I will run it on the new PC with Rhino 7 and the old laptop with Rhino 6 to compare the results. I will post you the results on the other Topic.

You can just delete the old folder with the RHP file you dragged in to Rhino as it should not have installed. Then just install the new one. If you use the RHI file it installs to the pluginfolder, if you unzip the rhi file and extract the files and drag the RHP file in you will need to not move the folder as Holomark looks for other files in that folder (display modes and some Rhino files)

Happy benchmarking, and sorry for it take so long to run the tests, it was not really built for Rhino 6 speed and new hardware at all… (just adapted to run on it).

Ok, Holomark worked, everything fine… just, where do I get the results page?

Once HoloMark2 has completed you’ll get a dialog with the text that contains all the results. And you should have one viewport set to a holomark view. If you don’t see anything maybe try ZE to get the graph in view.

This is what I get when Holomark completes the test. No dialog no nothing, just a mini cooper.

Any ideas?

@Holo will know better as he wrote the command.

Strange, it should work as it has verified that the different display modes are installed.
Did you install with the installer or did you unzip?

I’ll run the installer on my new machine that has a fresh installation of both v7 and v6 and I’ll check if I get the same issue.

I have done a fresh installation of rhino 7 evaluation copy. Then I installed the .rhi by doubleclicking on it and going through the installation wizard. then I launched the command and everything worked perfectly but the finish

@Holo FYI on my machine the font used to create the final text on the left side of the graph does not exist. So text creation failed for that part. If you look at my result in Holomark2_R6 - #265 by nathanletwory you’ll see that on the bottom left the text is missing.

Thanks, I’ll check it out.
Rhino used to be ok with rs.addtext() with no font, but that has changed a few times so I’ll see if that might be it.

What OS language are you on @gianandreafiorillo ?