History always on by default?


#1

Is there a way? would speed things up and would be more intuitive. Maybe dying after 1min like Snapchat to save resources :smiley:


History breaks for no reason
#2

Hi @hannesgrebin,

if you right click on “Record History” in the statusbar, do you have below option enabled ?

c.


#3

Hi! You can try to open a new file, turn on “Always record history” from “Record History” dropdown, and save it as the default template.


(Pascal Golay) #4

Hi Vitaliy - that is not a document setting, actually, it is a global application setting.

-Pascal


#5

Thanks. I forgot to mention I did not try it myself )


(Pascal Golay) #6

Hi Hannes - running a command prefixed with “#” toggles the history recording - so you could conceivably make a special toolbar or set of aliases that always runs commands in History mode and leave the global setting off.

e.g. ! #_Loft

-Pascal


#7

@clement would go with this simple checkmark, @pascal what is the difference with global settings compared to your #-approach (could even add a # to all my Aliases) ?

Thanks so much both of you, has even helped me this week many times!

H


(Pascal Golay) #8

Hi Hannes - I lied, above - I thought # toggles the history recording for the command but in fact it forces it to be recorded, regardless of the global state.

-Pascal


#9

No worries, but Is there any way to break history, because it interferes when copying and working on different geometries. Thanks. cut and paste would break it so far. But a simple command would be helpful. Thanks!

H


(Pascal Golay) #10

Hi Hannes - HistoryPurge.

-Pascal


#11

Great! Thanks…