Record comes on automatically

Certain commands automatically activate record…how do I stop this from happening? I know I can just click and turn it off but I don’t want to do that I just want it to stop automatically activating when it’s turned off! thanks

Turn off the ‘Always Record History’ option