Invert & Hide Extremely Slow After Last Update


#1

After updating to Version 6 SR5 (6.5.18155.13161, 04.06.2018) it started to take long time to invert selection and hide objects. Is there any way to fix this?


(Pascal Golay) #2

Hello - I have not heard this before - is this the case with any file or just some?

-Pascal


#3

Hi Pascal,
I checked again. This seems to be an issue with each file I work with. Even with very small files. It takes approximately 2 seconds for the task to complete while I’m sure it was much faster before the update. I don’t think it’s an hardware issue. I installed a plug-in recently but this was after the issue started to occur. I also recently get black viewport every time I start. I get 3 of 4 viewports blacked as seen in the screenshot. They function normally after I click on a viewport and zoom in or out. I am also attaching my hardware list, I am using a Quadro K2200. Thank you for your response. Please let me know if I can do something to help diagnosing the issue.


#4

Can you run the command SystemInfo inside Rhino and post the results?


#5

Here it is:
Rhino 6 SR5 2018-6-4 (Rhino 6, 6.5.18155.13161, Git hash:master @ 0e00e118078ee9a651d609817f672fb0ed8e83bf)

Licence type: Commercial, build 2018-06-04

License details: LAN Zoo Network Node

Windows 7 SP1 (Physical RAM: 16Gb)

Machine name: CAGLAR

Quadro K2200/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.13)

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: 8x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation

Render version: 4.6

Shading Language: 4.60 NVIDIA

Driver Date: 3-18-2016

Driver Version: 10.18.13.6213

Maximum Texture size: 16384 x 16384

Z-Buffer depth: 24 bits

Maximum Viewport size: 16384 x 16384

Total Video Memory: 4 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”

C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”

C:\Program Files\Rhino WIP\Plug-ins\RPC.rhp “RPC”

C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”

C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”

C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”

C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”

C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”

C:\Program Files\Rhino 6\Plug-ins\RhinoResurf\RhinoResurf_r6.rhp “RhinoResurf”

C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”

C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”

C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

C:\Program Files\Rhino WIP\Plug-ins\NamedPositions.rhp “Named Position”


#6

Well, I guess the first thing I would do is try updating the video driver, it’s from early 2016…


#7

I did update it to the latest version and it didn’t help. Although when I run Rhino in safe mode everything is smooth again in wireframe.


#8

Hmm, that does indeed seem like video problems… But I really don’t know how to proceed from here. @DavidEranen ?


(Bernat Lorente) #9

@cyzc Have you checked directly at NVIDIA website for a newer version? I think for there is a newer one: http://www.nvidia.com/Download/index.aspx?lang=en-us

Windows can’t find the newest version sometimes.


#10

Seems like it’s the Rhino Resurf plug in that is causing the issue, which I guess is written for Rhino 5. I disabled it and now it’s back to normal.


(Pascal Golay) #11

OK - thanks for letting us know.

-Pascal


#12

So,
same problem now on my computer… RH6 64bit and latest SR, Windows 7 64bit.
Takes extremely long if i use _invert _hide command
I run RH in save mode without all plugins and this works fine with the invert, hide
So it must be a plugin which causes this problem…
Activated one by one of my plugins to find out which is the “bad boy”

Finally looks like it’s the “VRay” Plugin - latest Version.

Georg


(Wim Dekeyser) #13

Have you contacted ChaosGroup to let them know?


#14

No, not yet now, i can do this, if this is the best way…


(Wim Dekeyser) #15

It is the only way (-;


#16

Does “Isolate” just do the same steps as invert hide or is it a different code?


(Wim Dekeyser) #17

I would think that it is the same code, just putting stuff into another container. @pascal?


(Pascal Golay) #18

Hi all - Isolate is using Invert plus the ‘hide buckets’ provided by the -Hide and -Show commands, but behind the scenes…

-Pascal