Hidden lines ugly in Technical display

Does anyone else find the hidden lines to be near useless for presentation/printing?

Specific problems are:

  • There are often multiple hidden lines stacked on top of each other of differing lengths, so they appear as a solid line, although it changes with zooming.
  • When printing, esp to PDF, the dashed pattern gets changed and appears as dot-dash - more like morse code actually.
  • No antialiasing. Everything else is antialiased, so the hidden lines looks especially bad now.



Hi Gavin,

Thanks for the feedback on technical display. I’ve filed two reports in our system (RH-23181 and RH-23180) for AA control and also improved PDF printing. The PDF print driver plays a part in the latter issue and I have tested it with PDF995 here and agree it’s pretty low res as well as different from the display. This may be something we can improve on but since it’s raster at the moment in technical mode I’m not sure until the developers can look into it.

In the meantime, try this workflow for creating crisp technical display pdf docs.

  • Run Make2D in the viewport of choice
  • Select Hidden Lines to be created and placed on their own layer.
  • In the Top viewport, zoom in on the Make2D result and hide other layers.
  • Right click the Make2D hidden lines layer and choose ‘select objects’ in the Layers panel.
  • In Object Properties, change the linetype to dashed
  • In Options>Document Properties>Annotation>Line types, change the scale for the dashed type to your liking.
  • Print to PDF using Vector output.

Hi Brian,

Thanks for looking into it. I’m trying to eliminate Make2d from my workflow, and use more of the awesome new V5 drafting features like history on dimensions to keep everything associative.

I appreciate that Technical is a raster output, but it would be great to just be able to set the DPI for it for printouts. On screen it isn’t too bad, because its just me seeing it. But when I do a printout it is for the customer and needs to look good. That being said, the overlapping lines appearing as solid would still need to be fixed.


I don’t know if it would be easier for the developers, but I’d actually like to have the option for hidden lines to be solid, that way I can set the color to a lighter shade, a thinner thickness, and it will look good.

1 Like

The dotted lines don’t show well in raster. A straight line that could be manipulated would be preferable.

Thanks for the feedback, I filed the solid line option for hidden lines as feature request RH-23195 for future reference.

1 Like

Hi Brian, having the possibility of showing hidden lines not dashed in technical display would be just perfect! Thanks, Lukas

I’m wondering if this has been resolved?

Rhino 6 technical shows hidden lines as dots and other weird graphics

Still not changed…

this should be the priority, not the flair thingy :frowning:

1 Like

since it looks like true vector technical display wont appear in the wip would it be possible at least enhance current raster output to look normal? i tried different dpis but hidden lines just look really bad and there seems to be no option. at least in display mode there could by setting for hidden line density