Hidden Line Hatches Bug (VisualARQ)

I love the capabilities of Hidden Line display mode from VisualArq. However, it looks like there’s a small bug with controlling hatch line thickness. The preview is correct on screen however when printing, some hatches default to hairline thickness, instead of the thickness I have set for them. This appears to happen at random. They display correctly in the viewport but not in the PDF. I have tried both AdobePDF and RhinoPDF printers.

See below, experiments with hatching;
How the hatches look in the Viewport;

Output PDF;

hatch3RhinoPDF.pdf (73.6 KB)

Please ignore the jankyness of the hatches, this was just my experimentation.
Hatches Experiments.3dm (789.6 KB)

Hi @Patt I’ve tried this and it works well on my end. There are some hatches that are printed with a thicker width, but those have the Print Width set to 0,35mm while the others have the Print Width set By Layer, which is a hairline.
What Rhino and VisualARQ versions do you have?

Thanks for trying this. I have R6 (Windows) and an up to date VisualArq.

Hi Patt, I don’t know how to help. I’ve tried this with Rhino PDF and CutPDF with your file, and it prints correctly. Which VisualARQ version do yo have? (It should be the 2.9.1) Which Rhino 6 SR version?

Thanks for getting back to me. I am still getting the issue - when I try with a new file, there is a discrepancy with prints from the Vector Viewport and from the Wireframe Viewport. My VisualARQ is out of date, so I will update that and try again (sorry, I thought it was up to date).

VisualARQ: Loaded (2.4 SR3, Build 13136, 2019/03/28)
Version 6 SR33 (6.33.20343.16431, 08/12/2020)

HATCH5(Wireframe).pdf (13.8 KB) HATCH4(Hidden).pdf (13.8 KB)

Updating to the latest VisualARQ fixed my problem. Sorry I didn’t try that sooner. Thanks for your help.

I’m glad it finally worked out for you.

1 Like