Help - render mesh is much to fine -> project file size exploded (Update: Display Mesher is broken per Update(?))


I sent a working model to my client. He modified the model and send it me back for rendering. But now the model size is exploded. The whole model was approx. 1GB but now it is 5GB. If I save the file “geometry only” and without plugin data the size is 600MB.

I found that some objects get a much to dense render mesh. I would be very glad if someone could give me a hint how to get back a normal project size. Maybe @Pascal or @nathanletwory have an idea, what is wrong here.

Here a screenshot - I tried a very raw render mesh, but it is always much to fine.

A quick help would very appreciated since I need the project done soon as possible.


WrongMeshing.3dm (7.0 MB)

Have you checked with PolygonCount to see if the issue really is the render mesh, and narrow down the problem objects? Is there bad geometry? Could it be some messed-up plugin data?

The polycount of the whole model is approx. 140.000.000 - this is upper record size. :wink:

Also the simpel part at my screenshot should show less than 10.000 polygons, but now it are 100.000 polygons. The black area at the screenshot are fine polygons, but I set an angle of 30°, so it should be a very raw polygon mesh only. Something is wrong here.

Is the object set to custom render mesh maybe?

It seems to be the extreme distance from the origin, messing up the mesh creation somehow. I’ve had models a literal mile wide in inch units show no such issues, but mm?

@Gijs No, I used the custom render mesh to test the meshing only.

@JimCarruthers The meshing was fine at my previous model state at the same place.

But it looks like I found a solution - after I set my raw mesh settings I started _RefreshShade and the mesh look I like expected now. It looks like my client reset my mesh settings and I adjusted it to my good old mesh settings, but the model wasn’t refreshed and stick on the wrong display mesh setup of my client. At the moment the meshing for the whole train is running and in a few minutes I will know what happens now.

To get of all mesh objects (that aren’t already meshes themselves) you can use _ClearAllMeshes.

Good to know, thank you.

If I change the display mesh options shouldn’t the display mesh be automatic updated?

Meshing my whole train seems to need some hours. I tested it for a single wagon and it doesn’t finished within the last minutes. I hope the train is meshed tomorrow.

(Unfortunately there is an old bug which reset the display mesh options from time to time and than the whole model is remeshed again with the wrong mesh setup. It happens sometimes if I look at the Rhino options and close the dialog without to open the mesh settings. But this is an other story. Maybe I lost my mesh setup by this bug. It’s an old bug from Rhino 5 which is still alive at Rhino 6.)

Approx. 10 hours later my model is still not meshed. I don’t know what I can do, meshing parameters and model are the same like at the last weeks.

Scene units Millimeter and

Hi Micha - It’s possible that there is one or a few objects that have problems. You could try to turn on layer by layer and wait until all new geometry that was shown is meshed before showing more objects. If there are few layers or huge amounts of objects per layer you could try hiding everything and then ShowSelected a few objects at a time. Put the viewport in Wireframe before you run ShowSelected.
If you can. upload a model, use the upload page and we will take a look.

Hi Wim,

I send you a model per PM. But also I found one tiny object, which can’t be meshed - see attachement. What is the reason that this object can’t be meshed? How can I find all object with the same problem? Is there a way to fix the situation?


NoMeshing.3dm (1.3 MB)

FWIW, this crashes Rhino WIP on the Mac (: looks like a memory-related problem.

edit: I think the Refine Mesh in combination with the Minimum Edge Length setting causes the problem. When I uncheck Refine Mesh and Simple Planes in meshing settings I end up with a properly meshed object. I believe that you should uncheck those for all custom render mesh settings as well in your project. The refining step is very computationally intensive and can take a long time.

For your carriage side object I suggest you use Density 0.1, Maximum Angle 0.0, Maximum Aspect Ration 15.0, Minimum Edge Length 1.0, Maximum Edge Length 0.0, Maximum Distance, edge to surface 0.1 and Minimum Initial Grid Quads 0. Refine Mesh and Simple Planes can both be on. I end up with 24k triangles.

And a test with Minimum Edge Length set to 100.0 gives an end total of 3770 triangles.

Thank you for the suggestion. General I have not so good experiences with the max aspect ratio, since I have seen strong slow downs for the mesh calculation per this option.

I wonder that the meshing parameters which I used since a few years doesn’t work anymore now. My impression is the last update destroy something at the mesher. Meshes get much to dense now. For example the screenshot of my first post should show a very low poly mesh with a few hundred polygons only. Large polygons should be visible only.

Here at Rhino 5 - only max angle 30° set cause 735 polygons.

Hi Micha - the model that you sent with the mesh settings as they are in that file meshes in a few seconds on my system.

I’ve let that one tiny object sit for over 3 hours here and it never finished.
I’ve created RH-56933 for a developer to take a look (and also RH-56932 for that model to crash on the Mac).

Do you have anything specific here to test? Which update - from a service release candidate, or between SR’s? A specific model? I tested that side panel that Nathan also tested with the settings that you used:
After forced triangulation, that created 1397 triangular polygons on Rhino 5 and 1389 triangular polygons on Rhino 7.

Hi Wim,

I’m at version Version 6 SR21 (6.21.19351.9141, 17.12.2019) and I don’t which version I used before (some days before I updated).

I have seen there is a new update and installed 6.22.20028.13281, 28.01.2020 in this moment, but I still have the same problem.

If I take the model from my first post than I get “There would be 179822 total triangular polygons in this selection after forced triangulation”. Rhino 5 gives me 735 polygons for max mesh angle 30°. This is a large difference.

Help - this is really a big big problem. I can’t work with my complex models anymore. A simple window panel of my train bring 386586 polygons in “jagged and faster”. I’m lost.

@pascal @wim @nathanletwory

I found the solution. In the past it was no problem to move the density slider at 0, but now a very small value is needed like 0.01 and anything works like expected.

I tested down to SR19 plus the current WIP, it’s everywhere the same. I don’t know why I don’t run in this problem earlier. I set the density like all unused mesher parameters at 0 since years.

Could be great if this pitfal could be fixed. :wink:

1 Like

I can’t reproduce that behavior here on my models, but what I noticed, is if I open your model, change the density to something else than 0, then ok, then reopen the custom mesh setting and switch density back to 0, the mesh is normal again.

my guess is that something went wrong in sending the model back and forth to your client. Or do you also have these issues on other files?