Help in lighting for Cycles Render: glass material bightness [Solved]


#1

I’m trying to set up Cycles Render to get lighting for glass material, but
having a little difficulty.
Attached is rendered image, I can’t seem to get the upper part of the glass
to be brighter.


Iittala_Glass.3dm (231.8 KB)

Also the render viewport looks a little bright, something in the settings I may have changed?


(Nathan 'jesterKing' Letwory) #2

I’ll check this either later today, or otherwise on Monday when work continues.


(Nathan 'jesterKing' Letwory) #4

The ‘dark’ effect in the glass is due to the use of shadow-only groundplane. You actually see the custom reflection and refraction environment through the glass. I haven’t found yet a good way around it - I probably will have to adapt Cycles core to work for the Rhino usecase better. The use case being that through transparent objects one would see the background, but reflections still would see the custom reflection env. It is on my eternal todo list to improve the shadow-only gp, though.

Changing the groundplane to a white material makes the glass appear brighter. But the ground isn’t full white anymore, because it is shaded. Alternatively you can unselect the custom reflection environment, but you obviously lose the reflections from that image.


#5

Hi @nathanletwory

I was looking through some tutorials of Cycles,
and for glass to look more transparent, transparent shader is mixed with the Glass shader.
Is this something that is possible to change in the material editor?

Is it possible to export import material files from blender to rhino?
(sorry beginner in blender)


(Nathan 'jesterKing' Letwory) #6

This we already do with glass. You can light objects through objects with glass. The difference is that we use the principled bsdf instead of glass bsdf.

There is no way yet to import Cycles materials into Rhino. You can use Grasshopper and my shader plug-in to create materials manually, though. I use it to create the material conversions: https://github.com/mcneel/RhinoCycles/blob/master/conversion/rhino_full_shader.gh


#7

Thank you Nathan.
I’ll try it out.

Just tried out, got a message as below, anything I need to install beforehand or
is it directory where the file needs to be?
(Sorry for taking your time)


(Nathan 'jesterKing' Letwory) #8

Yes, you need GhShaderNodes, but I haven’t published the latest version yet. I’ll post a link here when it is done.


#9

Thnx again!


(Nathan 'jesterKing' Letwory) #10

Good morning @Toshiaki_Takano,

You need to install the GhShaderNodes component v0.0.9 . Extract it to the special component folder of GH. After that you can open the rhino_full_shader.gh file.

/Nathan


#11

@nathanletwory
Thank you Nathan!
I’ll try it out!


(Nathan 'jesterKing' Letwory) #12

Ignore the awful icons, willfully copy/pasted. Someday in the future there will be Nicer Icons.

Also note that not all Cycles nodes have been wrapped yet into GH.


#13

I copied the above files[FSharp.Core.dll, FsShaderGraphComponents.gha, ShaderGraphResources.dll] here:
C:\Program Files\Rhino WIP\Plug-ins\Grasshopper\Components

and tried opening the rhino_full_shader.gh

Getting below Loading Errors:
(I feel I’m taking too much of your time now…, is it possible to ask for
glass bsdf+transparent shader material? or will that take more time?)


(Nathan 'jesterKing' Letwory) #14

Did you restart Rhino after copying the files?

Regarding glass in Rhino - as I mentioned we already do the transparent BSDF trick. So if you use the Rhino glass material you get glass with transparent bsdf trick applied.

The darkening problem you experience has to do with the environment together with shadows-only groundplane. The problem is not with the glass material.


#15

Yes, Rino rebooted also rebooted the pc just in case.

I’ll play around more with the environment setting to see how it changes. Thank you for your support again.


(Nathan 'jesterKing' Letwory) #16

Hmm, are you on latest public WIP from September 5th?


#17

As below:

Work In Progress
(6.0.17248.9001, 2017/09/05)

Hmm. Could it be that becuase I’m using Japanese OS WIN10pro?
Rhino is set to Eng.


(Nathan 'jesterKing' Letwory) #18

To be honest I don’t know. As far as I know that shouldn’t matter…


#19

Ok. Thanks again. I’ll try again once the next WIP comes out.
or when I find time maybe I’ll reinstall to see if that changes.

Just one additional question…
Is it possible to make material to be self-illuminated?
was wondering if in small amounts help…
or also in a case to use material as light source like leds.


(Nathan 'jesterKing' Letwory) #20

Rhino custom has a self-illuminating check. In Raytraced it affects the diffuse shading, so it won’t affect glass much.


(Nathan 'jesterKing' Letwory) #21

@Toshiaki_Takano,

I just found a better environment setup that works with shadow-only groundplane:

image

This is your scene rendered with that adjustment.

The fix will be in the next WIP (reported as RH-41286 )