Cycles - light inside transparent object

Hi @nathanletwory
Is there a trick to getting light inside a glass/transparent plastic container? I’m trying to do a rendering of a drinking bottle, and the filter inside (white plastic) is almost pitch black. There’s an awful lot of settings, and I have no idea what 90% of them do :no_mouth:
TIA, Jakob

Have you tried using the Plastic or Glass materials instead of the Custom material?

Hi @nathanletwory
Thanks - figured it out… It’s the skylight/hdri/ibl that doesn’t “work”, so I need to add point/spot/rect. lights to get some light in there. Is this expected behaviour for Cycles or is there a setting?
TIA, Jakob

I’m not sure I fully understand what you are seeing.

Here a quick shot of a box with glass material and only the Dublin Studio environment as the skylight:

The sphere inside has white plastic. Dublin Studio has light coming in from one direction, you can see the shadows cast on the ground plane - I set a plaster material on the ground plane to illustrate the shadow. No other lights used.

Argh! Sorry @nathanletwory - I’ve been sending you on a wild goose chase! I thought I was in the WIP, when really I was working in V6. I’m going back and forth all the time, and I simply lost track of what version I was in. All is well in the WIP, but in V6 I’m still seeing this weird degradation of light/colour. I think I remember this being brought up before, but can’t remember if it’s a bug, setting or limitation.
Again, sorry for sending you in the wrong direction!
-Jakob

Rhino 6 SR17 2019-8-23 (Rhino 6, 6.17.19235.15041, Git hash:master @ 06b69c5cc21d880aa793a5a7cfd454a66f6213bb)
License type: Commercial, build 2019-08-23
License details: Cloud Zoo. In use by: Jakob Normand ()

Windows 7 SP1 (Physical RAM: 32Gb)
Machine name: NIK-Z620

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1080 Ti (NVidia) Memory: 11GB, Driver date: 7-17-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.60

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-17-2019
Driver Version: 26.21.14.3160
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 11 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot8RhinoPlugin (6c7d7caf-b4ba-406d-bfaa-8d719d8212c3)\1.0.0.0\KeyShot8RhinoPlugin\Rhino 5.0\KeyShot8RhinoPlugin.rhp “KeyShot8RhinoPlugin” 1.0.0.0
C:\Users\nik.BONNELYCKE\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.6.14.669\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”
C:\Users\jn\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\rhino-render-next\0.0.2\RhinoRenderNext.rhp “Rhino Render Next” 0.0.2.0
C:\Users\jn\AppData\Roaming\McNeel\Rhinoceros\packages\6.0\rhinopbrmaterial\1.1.0\RhinoPbrMaterial.rhp “RhinoPbrMaterial” 1.1.0.0

Not sure what to say - the glass box render I posted was done in v6.

Here a glass and twisted box in V6:

Can you perhaps share the model of the renderer you showed?

Hi again @nathanletwory
Strange! Here are both files (although I guess they should be identical) saved from R6 and R7. Tried to reset raytraced mode (just in case I messed something up), but result is still the same :thinking:
Let me know, if there’s anything I can do to to help pinpoint the problem. I’ll just stick with R7 for now :slight_smile:
Regards, Jakob
Glass V7 WIP.3dm (7.1 MB)
Glass V6.3dm (7.1 MB)

Strange indeed, here is what it looks like in my V6

image

I see you have Keyshot in your plug-in list. Is it by any chance set to be the current renderer? If it is do things look better when you set it to say Rhino Render?

Just tried to load protect all plugins (that don’t ship with Rhino) and no change. The KS-plugin is just an exporter, not an actual render engine (it basically enables live linking between Rhino and KS, which is a stand-alone). Had the Rhino Render Next plugin installed as well, and thought that it might be the culprit, but no dice! I guess, I’m the only one seeing this, so it must be something very system specific. I’ll just try and update my graphics card driver - just in case. Since it’s working in V7, it’s not a bag thing - just weird!
-Jakob

Very weird indeed. It looks like two materials get mixed for some reason. But not sure what is happening there, it is a mystery. If I can reproduce it in the future I’ll certainly fix it :slight_smile:

btw, since you have this problem with v6 I’ll change category to #rhino-for-windows